9

Lately, I have been having a problem with a particular printer. Its an HP LaserJet P1006 printer, small compact, almost cute looking, but don't be fooled! For whatever reason, this devil machine hasn't been working on a particular computer that needs it. All my attempts to get it to work for more than a day have all failed, either because the printer is a spawn from hell or the computer just doesn't like it.

Once again the printer is an HP LaserJet P1006 and the OS is Windows 7 32-bit on a Dell Optiplex 790. The symptom is that the document errors out in the queue. Checking the event log I find that there's an error in the Spooler service. The Event ID is 372 and the error code is 87, saying the parameter is incorrect.

What I have tried so far:

  • Installed latest drivers
  • Tried the HP Diagnostic tool, which apparently thinks everything is fine
  • Reinstalled latest drivers
  • Uninstalled drivers then reinstalled latest drivers
  • Uninstalled drivers and completely wiped out any trace of the drivers existence from the computer, from the PnP package to the print manager to anything on the drive with its name to any trace left on the registry, cackling like a mad medieval king bent on wiping out a rival dynasty. Then reinstalled latest drivers.
  • Replaced the USB cable
  • Tried several different USB ports
  • Begged the printer to work
  • Threatened it violence
  • Updated to the latest chipset drivers
  • Restarted the Print Spooler service
  • Turned it off and then on again.
  • Wiggled the cord a little bit
  • Tried to convince the printer to work through peer pressure, 'All the cool printers are working!'

And the kicker: I replaced the printer with one of the same type and the result? It can print... for awhile, then it ends up like the demon printer. Both of these printers work fine on other machines so it has to be something between the machine and the printer.

Before I completely uninstalled and reinstalled the drivers on the PC, items in the print queue would show up for a second and then disappear without a trace. Now it seems like items are just getting stuck in the print queue with it saying that an error occurred.

How can I bring peace between these two warring factions, the PC and the printers? Is there any hope for this computer, or myself? Or will I be lost to madness in my attempts to fix this problem?

  • 1
    @Foosh He already mentioned trying to restart the Printer Spooler service. – Michael Frank Nov 12 '14 at 23:28
  • 1
    @Superkroot I meant of course a different model, I did read your question afterall despite what you and MF seem to think... You could check your system event and error log for anything related to the printer, driver, connections, etc. Since this is a USB connection are you experiencing any issues on other USB devices on this machine? Might be a BIOS/UEFI setting that's out of whack. – Foosh Nov 12 '14 at 23:35
  • 2
    Great description of what you tried to fix the problem, but I'm missing exactly what is the problem. What, exactly does or doesn't it do? Is it independent of any specific application? How far does the process get (any activity of any kind on the printer)? Any indications of any kind in the application or printer dialogue? Were you facing east when you spread the goat entrails under the full moon? – fixer1234 Nov 13 '14 at 0:05
  • 1
    @fixer1234 Nothing seems to happen other than the document erroring out in the queue. Checking the event log I find that theres an error in the Spooler service. The Event ID is 372 and the error code is 87, saying the parameter is incorrect. I have no idea what this means. Also, gorilla entrails? Do I look like I'm made of ritual sacrifice supplies!? We do all our IT work with vulture bones and cougar blood here! – Superkroot Nov 13 '14 at 0:54
  • 1
    have you seen this: h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/…? This suggests you're not the only one – mcalex Nov 13 '14 at 3:41
1

Since two different printers of the same model behave this way on the same computer, but works good on other computers, it sound like the printer drivers and the operating system (or at least some module/service of it) are experiencing some kind of incompatibility.

I am not sure what partition configuration you have on computer or if you even think it is worth doing what I am about to suggest for a potential fast-solution; you may try to reinstall the operating system (or make a dualboot) and see if the printer will work for more than "a few days" that way.

  • 2
    Upvoting this and closing the question. I managed to fix the problem last week and forgot to update this, but this was about the solution I came up with, except I did a Restore point back to before the problem started and now it seems to be working. – Superkroot Nov 17 '14 at 18:41
  • 1
    Don't you just love it when something you do fixes a problem, but you still have absolutely no idea how it originally occurred or what was really wrong? I used to experience that a whole lot more before I switched to Linux. BTW I have an HP1006 working nicely on Linux. My HP1020 has recently become somewhat less cooperative. – Joe Nov 19 '14 at 5:58
0

This might be spooler or old drivers problems. I suggest you remove all printers and then follow this procedure :

  1. Open a command prompt.
  2. Type : printui.exe /s /t2
  3. Delete all printer drivers
  4. Restart 'Printer Spooler' service

Source : http://techsultan.com/fix-corrupted-printer-drivers/

  • 1
    Already did this when I cleansed the computer of every foul trace of the corrupted drivers. The bards sing of it even to this day! – Superkroot Nov 17 '14 at 18:42
  • Did you do it in safe mode ? – Fraser Marks Nov 26 '14 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.