4

I've tried to find a solution, but I haven't had much luck. The photo says it all:

enter image description here

I'm supposed to have 4 cores, but they're not showing up. What gives? msconfig advanced boot options also only show one processor.

  • Right-click the CPU graph, click "change graph to," and click "Logical Processors." Does the graph split into eight? – Shane Di Dona Nov 13 '14 at 3:26
  • No...the option is grayed out. I already tried that based on my research. – Nathan C Nov 13 '14 at 3:30
  • Thought about that too. Core count and logical processor count is completely off. – Journeyman Geek Nov 13 '14 at 3:47
  • Are all the drivers installed? Is this a new problem on a computer that previously displayed all 8 logical processors, or is this a fresh install/build? – Shane Di Dona Nov 13 '14 at 3:49
6

There are a number of things that can cause this, and here are several possible fixes.


ACPI bugs in your motherboard's BIOS can cause this problem. Ensure that you are running the latest BIOS/firmware for your motherboard.

On that note, did you upgrade Windows recently? If so, then you may need to update your chipset drivers.


In msconfig, uncheck the box to set the number of CPU cores. Then shut down the computer.

enter image description here


A third party utility called EasyBCD can reset the number of CPUs Windows thinks it has. Despite it apparently controlling exactly the same thing, this has been known to work when the msconfig setting above failed.

  1. Download EasyBCD from a reliable web site (such as its official site).
  2. Click Advanced Settings, then go to the Developer tab.
  3. Set the option Limit Windows to xx CPUs to 0 (zero).
  4. Shut down the computer, so that it powers off.

When you power on the computer again, Windows should figure out how many CPUs you have and fix itself.


Another possible fix is to delete your CPU from Device Manager, and then restart your computer. This causes Windows to redetect your CPU, hopefully correctly.

While you're in Device Manager, see if anything else is reporting a problem, and fix it.

  • It was the chipset. I posted the results as an answer but I'll accept yours since it was accurate enough. – Nathan C Nov 13 '14 at 4:10
2

Well, turns out it wasn't as bad of an issue as I thought. After I installed the chipset drivers for my motherboard and rebooted, the cores showed up.

Sometimes the most obvious answer is right in front of me.

0

This is for anyone having the problem like I was, try this.

I had my drivers installed and was still only showing 1 view.

Right click the graph, hover over change graph to, then select logical processors.

  • This is quite old, but there was no processors actually showing up at all since I didn't have the correct chipset drivers. :) – Nathan C Aug 1 '17 at 21:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.