3

I have Windows 8.1 installed on a machine with an i5 at 2.5 Ghz and 16GB of installed RAM. There is about 80GB free disk space. When I'm trying to move one file from one folder to another, I get this error:

There is not enough memory to complete this operation.

The size of the file is a bit under 3 KB. The system barely uses 2GB of memory right now. I also let the system manage the virtual memory settings, since I thought maybe changing those would create some unforeseen problems. But still Windows 8.1 can't move a small file from one place to another, although there are plenty of system resources. I'm also using admin privileges so I don't think this could be an issue.

7
  • 1
    Does it copy using Roboycopy or xcopy. Can I assume your copying from and too the same hard drive? – Dave Nov 13 '14 at 15:13
  • 1
    So if you select a empty text file can you copy the file? If you can't do that then you have serious system integrity issues. – Ramhound Nov 13 '14 at 16:09
  • 1
    Wonders if there is compression involved here somewhere? that it isnt a folder, but a zip ? or some thing along those lines? Or some container encryption? – Psycogeek Nov 13 '14 at 16:17
  • 1
    Possibly related KB: Error message when you try to copy files from a Windows Vista-based computer to another computer by using Windows Explorer: "Out of memory There is not enough memory to complete this operation". Also, are you trying to move a file to a system folder? If so, you usually need to use Explorer (drag and drop) to avoid misleading error messages related to permissions. – jww Nov 13 '14 at 16:44
  • @Dave - I tried to drag and drop a shortcut from one folder to another on the same hard drive and same partition. My guess would be that it is somehow related to some mixed up privileges. It's not the first time I see this problem on Win8.1. I am logged in as admin on the system, but sometimes Windows prevents me from doing simple file manipulation operations on documents (not system files or other critical data). – dolanator Nov 15 '14 at 12:16
2

I have been facing same issue for a while, found that the shortcuts which give this error are actually in Public Desktops. Go in users>public>public desktops and delete it from there. It will update user specific desktop as well

1

I got similar problem with pdf file I couldn't copy on usb I just pack it to archive and after this Win 8.1 have no problem with it any more.

1
  • 1
    Very unlikely. The file mentioned by the OP is about 3 KB in size. – bwDraco Jan 16 '15 at 3:39
1

It's just a misleading error message. The true cause is likely to be the permissions issue: Copying a file on Windows 8 gives “not enough memory” even with plenty of memory and disk.

Quote from the answer:

I downloaded Teracopy and tried using that to copy the file; it too failed but gave me a much better file error message: "Open Error: Access is denied"

I check the file Security Permissions (right click Properties --> Security) and indeed the current user did not have Read Access. I add the permissions and it copied fine.

0

I got the same error when trying to move a PDF (2MB) file into another folder. I'm running Windows 8.1 with similar resources on my machine.

Turns out I had the file open in Adobe Reader and closing the file fixed the problem.

I recreated the error as well, so not a one-off. Perhaps this is a case of a bad error message

Not the answer you're looking for? Browse other questions tagged or ask your own question.