I have a 2.1 Creative speaker system. While I'm happy with the sound quality, there's a small amount of noise or cracking sound being produced when the speakers are not in use (ie. no audio being played). What's causing this and how do I fix it?

I've read this question, and it's definitely not the same problem. One thing I've noticed is that it happens when I switch from Avast to a different antivirus, which makes me think it might be a software problem.

  • Are these amplified speakers? Are your cables screened from EM interference? Dec 16, 2009 at 9:12
  • EM Interference... hmmmm... possible .. because I keep speaker, CPU, UPS and Monitor altogether .. How much distance it(/they) need to be separated you suggest ? Dec 16, 2009 at 9:16
  • Then ... what is the scenario with AV .. ? Dec 16, 2009 at 9:20

5 Answers 5


Besides eliminating interference, another suggestion:

Turn down the sound card/chipset volume from 100% to 75%.

Turn down inputs to the sound card/chipset from 100% to 75%.

Then, use the speaker's amplifier to compensate for any deficit in listening volume.

Why does this work? Amplifiers amplify, and when there is no useful sound to amplify, they will amplify noise. By turning down the sensitivity of their inputs and the volume of their outputs a bit, you'll cut the noise a lot.

In addition, it may improve your audio sound quality. When everything is set at or near 100%, a form of distortion called clipping occurs. This is when the tops and bottoms of sine-like waves get cut off flat, because they exceed the capacity of the amplifier (or sensitivity of the pre-amp inputs, etc). The result looks more like a square wave than a sine wave and sounds more like a square wave, too.

  • oh .. I see .. I will follow it up .. Anyway I don't use 100% output .. :) thanx for the answer .. Dec 16, 2009 at 17:01
  • I know, I made it too late to thank you .. but anyway I would like to say you have got the right point .. I had tried all other solutions but finally concluded that its the same issue what you have mentioned .. I have reduced the windows o/p volume to less than 70% .. and its all fine now .. :-) Jan 27, 2010 at 17:51
  • Never too late, you're welcome.
    – kmarsh
    Jan 27, 2010 at 22:00
  • In my case I had to do exactly the opposite which is to increase the windows settings to 100% while reducing the amp volume on the speakers theselves to the bare minimum. That eliminated a constant "buzz" and a super annoying repetitive "OOO-GGGG-ZZZ" sound that was happening every 3 seconds. However, this uncovered a pre-existing silent contstant "fsssss" white noise that is there even if I put all available settings to 0.
    – thanos.a
    Jul 12, 2020 at 6:37

It's definitely not a virus issue.

As the comments say, it's in all likelihood normal electrical interference. It's quite common in unshielded audio/speaker cables.

Try moving the speakers/woofer around a bit, hopefully you'll find a place that minimizes the interference.

Another thing you can try is to update any audio drivers you have, there is a small chance this could help.

  • 2
    Yeah, I'd go with wiring/cable issues as well (also make sure it isn't just occasional noise when your mobile phone is in the vicinity).
    – Bonus
    Dec 16, 2009 at 10:42
  • thanx for the answer .. .. Dec 16, 2009 at 11:28
  • ohhhhkey ...... thanx to (the) BONUS too .. Dec 16, 2009 at 11:29

I remember having this problem on windows XP, what OS are you running ?

on Xp, I simply get into the "Sounds proprities" and mute all the others devices (wave, Mic ...), make sure your speakers are set to the appropriate speakers type and your micropfone is not using any "gain boost" or such feature.

  • ya its XP .. making wave, mic mute doesn't make any difference .. :( My speakers have been set to proper type 2.1 sub-woofer .. I don't know, how to Reset/Set the microphone property .. please clarify (may be thats the prblm, I am suppose to tr it ..) .. Dec 16, 2009 at 11:26
  • Actually .. I am glad that someone faced the same problem .. I need not be panic anymore .. Dec 16, 2009 at 11:27

Are you sure it's the speakers themselves and not the computer's sound output? I've been finding that since sound has been included on motherboards (instead of requiring add-on boards) that this is common occurrance. For whatever reason, it seems that on-board sound picks up a LOT of interference and sends it out the speakers/headphones. Especially if you've got the cpu set to be able to idle down to less than full speed.

  • ohk .. ya .. I have kept all the components of my Desktop more distant to each other Dec 16, 2009 at 16:58

Please reduce the mic volume. The noise will be terminated. You can do it by following steps. Click Speaker icon in Taskbar. Click Mixer. Reduce the volume Microphone (Hidefinition device).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.