2

I have a Windows 10 VM on Azure, to which I connect using remote desktop. Today I installed the latest preview build on it, and now I can no longer connect using RDP: my credentials no longer work, and I don't have any others.

What can I do to regain access to my VM?

5
  • Have you tried a forced restart? – Ramhound Nov 14 '14 at 15:21
  • @Ramhound, yes, it didn't change anything – Thomas Levesque Nov 14 '14 at 15:30
  • It sounds like your only choice is to rebuild the virtual machine. It sounds like something happen with the update. This is to be expect with pre-beta software. – Ramhound Nov 14 '14 at 15:31
  • @Ramhound, in this case, it's probably what I'm going to do, because I don't have anything important on that machine. But what if it happens on a VM where I have critical data and/or applications? There must be a way to access it when RDP isn't working, right? – Thomas Levesque Nov 15 '14 at 14:36
  • That would be a question for Microsoft. If you have critical data you might want to keep backups of said virtual machine. I am sure Azure has some mechanic that can make that process easy. – Ramhound Nov 15 '14 at 16:02
2

I managed to access it again by resetting the password using Azure Powershell:

Get-AzureVM -ServiceName “xxx”-Name “xxx” | Set-AzureVMAccessExtension -UserName xxx -Password xxx | Update-AzureVM
1
  • I've reseted the password with your script, and it says OperationStatus = Succeeded, but still no way to log on to the server. – Balint Jun 21 '15 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.