1

I have an iPhone 4s which was stuck in Recovery Mode after performing an update to iOS 8. I'm trying to use tinyumbrella to kick the device out of the recovery mode. However, each time I run the tool, It opens a small black window and stays like this, for ever.

Some info you should know:

  • I disabled my anti-virus, my windows defender, and my Firewall before running the tool.
  • I have the latest iTunes version (ver. 12.0.1.26)
  • I have the latest Java installation (ver. 8 update 25)
  • I used the latest version of tinyumbrella (ver. 7.12.00)
  • I tried running the tool in Compatibility Mode (Win XP SP 2)
  • I even tried older versions of the tool (6.14.00 and 7.02.01a). They showed a black window which closes after a few seconds.
  • I did not jailbreak my device, in case the tool work with jailbreaked devices and I missed that somehow.

Thanks in advance.

2

Replace the file in: C:/"Your username"/.shsh/.cache/lib-win.jar by this one: http://www.mediafire.com/download/hvnyj642jdy5dn9/lib-win.jar. I had the same problem. It works. (In my case windows 7 home premium 32bits + itunes 12 + java JDK 7u71)

You can thank Drake: https://answers.yahoo.com/question/index?qid=20140602200815AA5nCMj

3
  • Please don't link to an untrusted download. – bwDraco Nov 17 '14 at 5:31
  • I found an article that describes the same solution; replacing the jar file. Thanks for sharing! – iTurki Nov 24 '14 at 4:59
  • This works. Here is the verified article: inati0n.com/… – JoeM Jan 19 '15 at 17:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.