5

Can you help me guys with my problem? I am using Windows 7 and I get 169.254.x.x IP address. What would be the problem? Can you please gave me a step-by-step procedure?

Here’s what I have tried:

  • ipconfig /all got us a 169.254.x.x ip address and no default gateway
  • ipconfig /release gave us the same number
  • ipconfig /renew failed
  • also tried to check cable and done hard reset for both modem and router, still not working
  • 2
    A 169.254.x.x usually means you are not connected to anything. So the question is what other details can you provide to help us provide you with assistance with this issue? – JakeGould Nov 15 '14 at 5:19
  • In later operating systems like windows 8, 8.1,10 APIPA can be due to ipconflict. at that moment you have to find and resolve that issue as well.. windowstechinfo.com/2013/07/… – Aravinda Jan 30 '16 at 14:36
8

A 169.254.x.x means the computer has physical ethernet Link, but cannot get an IP address from your router. You can try following things:

  • use another ethernet cable
  • try use wifi if available
  • use another computer or smartphone to check if the router is working, and check router log for errors
  • if you know the IP of the router, set a static IP on your computer.
2

You are set up for a DHCP server but the DHCP server was not found so your system defaults to Automatic Private IP Addressing (APIPA). Normally your router would provide your DHCP IP addressing unless you have a static IP. If your router was provided by your ISP then I suggest you contact your Internet Provider.

0

Go into both the system that is getting the 169.X.X.X address and the router and set yourself a private address, because what it is is the DHCP isn't working. I've run into this before and the only way I know to fix it without tossing the router is to set a static for the PC in question.

  1. To do so first go into the router and see what kind of addressing you are using. Most have a 192.168.1.x addressing schema.

  2. There should be a place in the router to set up static routes, usually under "LAN IP Setup" or the like. Sorry I can't be more precise but every router is different.

  3. Once you have set up a static route for that system you then go Start > Control Panel > Network and Sharing Center.

  4. On the left you'll see "Change Adapter Settings", click on this.

  5. Once you are on the screen with your adapter right click and choose properties.

  6. In this screen choose "Internet Protocol Version 4 (TCP/IP V4)" and hit properties. pick "choose the following address" and input the address you chose on the router, the subnet will be 255.255.255.0 if its a 192 address and the gateway will be the address of the router. For the DNS you an use the one given by the ISP or any of the free ones, if you need a couple Comodo Secure DNS is 195.46.39.39 and OpenDNS is 208.67.222.222.

There you go, hope this helps.

0

Like others have mentioned, you computer can get an address from your DHCP server. To overcome this challenge, you can set a static IP or try other methods as posted here.If you are sure your router is working fine and doesn't need a reset, You can try this. The idea is to make your computer able to send dhcp request message once it connects to a network.

  • Disconnect from your WiFi network and enter the following commands in your terminal (run as admin same as elevated command prompt)

  • Type ipconfig /flushdns #This purges the DNS resolver cache.

  • Type ipconfig /registerdns #This Refreshes your DHCP leases and re-registers DNS names. (Note you are still offline)

  • Then Turn on Wi-Fi or plug in LAN cable. if it does not work, start with ipconfig /release and repeat the two commands above.

  • 1
    Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. DNS has nothing to do with DHCP. – DavidPostill Nov 11 '16 at 9:27
  • 1
    Welcome to Super User! Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Nov 11 '16 at 9:29
0

I found after checking cables, among other things it turned out despite the fact I could wirelessly connect to my router, a router reset actually resolved the problem.

A dead giveaway that the issue was the router was that even when setting a static ip I couldn't ping my router using LAN only. Another dead giveaway was that on the router I specifically dedicated an ip to the LAN connection outside of my DHCP range. EG: DHCP should have returned the dedicated IP address, but instead was giving the junk address, whereas my wireless card using DHCP was retrieving it's own dedicated address perfectly fine.

Connect to your router (possibly w/ another computer) and dedicate an IP address to each device you'd like to test (outside of the DHCP range so you'll have a definitive confirmation DHCP worked and recognized your device's MAC address), similarly do the same w/ a wireless device, then make sure all of them are using DHCP. If some wireless vs wired device is working where another is not, (EG DHCP is definitely working) your router may be at fault.

If you find this is the case, know your frustration isn't in vain because even if you manually configured the right IP to start with your router effectively was a brick the entire time, no amount of software steps would've solved the issue.

Note: as far as I can tell it seems other people with this sort of issue complain about cabling, which is why I brought it up. Whereas for me it turned out my router was on the fritz, I have no idea but it could be a bad cable/port that could cause this.

If worst comes to worst, you may need to find an old router to see if it has the same issue.

If the absolute worst comes to worst, you may need a new lan card...

TLDR: 169.254.x.x are addresses given when your device fails to retrieve an ip address from a DHCP server (your router). EG. If you've gotten so far as to find out you're being handed a 169.254.x.x address, you're more than likely having a hardware problem, either

  1. find out if a wireless device or card works w/ DHCP enabled (your router for some reason is no longer handling DHCP requests via lan or...potentially more like in my case) or
  2. set a static ip and see if you can bypass the issue by ignoring DHCP, you can avoid ip collisions w/ arp -a (you may need a second device).
  • Please read the question again carefully. Your answer does not answer the original question. "done hard reset for both modem and router, still not working " is stated in the question. – DavidPostill Nov 25 '16 at 11:01
  • Well you're right, he was asking for a software solution, and since I just recently had this problem and just solved it by happenstance I figured I should mention the router itself may have just gone bad. Aside from the basic networking diagnostic tools, which he seems aware of I figured it'd be best to mention for instance (in my case) it was a hardware failure and perhaps to test and isolate that first. (Now it seems he isn't as lucky and a hard reset didn't help him) Mostly in terms of software I figured I should share my method for figuring out if the router was handling DHCP properly. – TheUnknownGeek Nov 26 '16 at 10:02
  • If for example he's manually added a default gateway (the router's ip) and default dns (a fallback of the default gateway for good measure), the router and computer's lan led's are flashing the way they're supposed to (he's replaced the cable for good measure) and he's just got his one device, and he's walked through all the other people's steps. I wouldn't have much to add except to try replacing the router...as frustrating as it may be. – TheUnknownGeek Nov 26 '16 at 10:26
0

On the modem when I added a new set of Subnet Pools covering additional IPs, this problem solved for my Lenovo T420 with Windows7

-1

Run anti-malware software such as Malwarebytes Anti-malware.

Be as an administrator in the command prompt window, type the following:- 1) ipconfig /release (this command may or may not fail, proceed even if it fails) 2) netsh winsock reset 3) netsh int ip reset 4) Reboot your computer.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.