1

I have followed these steps to install windows 7 home premium x64 on a 3tb drive (asus z87-z motherboard):

Windows Setup: Installing using the MBR (Master boot record) or GPT (GUID Partition Table) partition style

In the console window, diskpart, I ran:

select disk <disk number>
clean
convert gpt

Then when using the GUI to partition the disk to install windows, it always reverts back to MBR (list disk shows no asterisk under gpt).

I tried again, in this case cleaning and converting the disk, then pointing windows at the partitioned disk and letting it install.

By going to Control Panel-Administrative tools-Computer Managment-Storage-Disk Managementand checking the properties of the disk I can see that it is now a MBR.

Is there something I have missed? Could there be something in my setup incompatible with GPT that is causing this?

  • May be that I'm not installing windows in UEFI mode? Is that a boot option? – Nathan Cooper Nov 15 '14 at 11:12
  • That is the first thing that comes to mind given all the information you provided. it Compatability boots after the intital load up of the disk ? Because the bios/uefi was set to legasy boot first or something? In the boot and CSS sections. – Psycogeek Nov 15 '14 at 11:15
  • Right. I solved my problem: I made sure I was booting from dvd in uefi. I disabled fast boot and set secure boot to "other OS" (ie off) [Can't comment on whether this was required, sorry]. I then did the cleaning and convert again. Windows Still gave the warning that it couldn't install and manual partitioning resulted in 2.2tb max partitions. So it didn't do it manually, I just pointed at the cleaned and converted disk and let it install. Checked, and it seemd to have worked. – Nathan Cooper Nov 15 '14 at 12:06
  • I found this related question: superuser.com/questions/616340/… Which is what gave me the idea to turn off secure and fast boot. – Nathan Cooper Nov 15 '14 at 12:07
5

When your computer turns on, press the appropriate F# key on to enter your system's BIOS/EFI. In there look for a mode setting that allows you to choose between booting in CSM (Legacy), or EFI, choose EFI mode.

Save your changes, exit the BIOS/EFI, and boot up the Windows installation disc. You should now be able to format the disk as GPT, and install to it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.