3

I keep having to restart my computer after leaving it on for a day or so in Windows because my "Modified memory" (whatever that is) goes absurdly high and I begin getting "Memory too low" errors, despite having 16GiB of memory.

http://s11.postimg.org/hulr1egvn/memorytoolow.png

I have no idea what to do here. How do you force free modified memory? I have 10GB free on my primary SSD if that matters and a 32gb pagefile.

Hardware:

Operating System Windows 7 Ultimate 64-bit SP1

CPU Intel Core i7 2600K @ 3.40GHz

RAM 16.0GB Dual-Channel DDR3 @ 802MHz (9-9-9-24)

Motherboard ASUSTeK Computer INC. P8Z68-V GEN3 (LGA1155)

Monitors DELL U2410 (1920x1200@59Hz) & Acer AL1916 (1280x1024@60Hz)

Video Cards 2047MB NVIDIA GeForce GTX 560 Ti (EVGA) & 2047MB NVIDIA GeForce GTX 560 Ti (EVGA)

Storage 1863GB ATA WDC WD2002FAEX-0 SCSI Disk Device (SATA) & 238GB ATA Samsung SSD 840 SCSI Disk Device (SSD)

Optical Drives ATAPI iHBS112 2 SCSI CdRom Device (Blu-ray read/write)

Audio Creative X-Fi Audio Processor (WDM)

Peripherals Logitech HD Pro Webcam C920, Logitech Performance MX Mouse, Genius SW-G2.1 2000 - 45 Watts RMS Speakers, Dell 101-Key Keyboard

  • 3
    Why are you trying to force the memory to be free, if its required, Windows will allocate it to your task. "Memory too low" errors is a virtual memory problem – Ramhound Nov 15 '14 at 16:10
  • 1
    Do you use a Broadcom WIFI device? If yes, update the driver or stop the program BCMWLTRY.EXE – magicandre1981 Nov 15 '14 at 16:12
  • Look at my screenshot though - the Modified Memory is huge. And I only have Chrome open with two tabs, Skype, Pidgin, a word document open, and Steam. That's it. I shouldn't be getting "out of memory" errors on 16gb of RAM with this setup! No Broadcom Wifi sadly. – user798080 Nov 15 '14 at 16:23
  • post your used hardware please. – magicandre1981 Nov 15 '14 at 16:29
  • 2
    You have the large modified memory because the Commit charge is 100% and it cannot be written to the page file. As the commit of processes doesn't add up to 48GB, it is likely to be a driver leaking Paged Pool. You can use Poolmon to check this blogs.msdn.com/b/ntdebugging/archive/2012/08/30/… – David Marshall Nov 15 '14 at 17:45
2

In my case purely through trial and error, I tracked it down to runSW.exe (some Realtek application with corresponding service. Not clear what use it actually has)

As soon as I stopped this service, my System Commit, Physical Memory usage, and that dreaded 'Modified Memory' all dropped off like a cliff.

  • Realtek is very popular among m/board manufacturers for sound and Ethernet chipsets. Check for updated drivers for these; they might fix that bug for you. – Chromatix May 9 '18 at 11:37
1

You are getting "out of memory" errors because your commit charge is at 100%, and some program is trying to allocate more private commit.

Do you have a pagefile? If not, create one. If you do, make it bigger, or add another.

Or, check task manager for the program(s) with the most "commit size", and close some of them.

The system cannot write most modified pages without a pagefile.

  • I have a 32gb pagefile. That should be more than enough I would think. And if you check out my screenshot, the committed memory isn't terribly high. – user798080 Nov 15 '14 at 16:21
  • The graph in the right column shows that your committed memory is at 100%. – Jamie Hanrahan Nov 15 '14 at 16:24
  • That is correct, but if you look at the list of processes, it is arranged by committed memory and if you add the numbers up, they don't add up to anywhere near 16gb. They add up to about 2.4gb, which matches my "In use" memory. The remainder of the memory seems to be eaten up by this mysterious "modified memory" section. – user798080 Nov 15 '14 at 16:25
  • @user798080 Probably you have hundreds of processes that each by one make a total use of 100%. – Little Helper Nov 15 '14 at 16:48
  • 1
    btw, the "in use" number there is physical memory, "commit charge" is virtual. You're comparing apples to oranges. It's only coincidence that the two numbers are similar on your machine. There's a lot of physical memory that's "in use" but is not used by committed virtual memory. – Jamie Hanrahan Nov 15 '14 at 19:08
0

Has it always done this? Have you run a mem test? What does the commit look like when you restart; do the numbers still not add up? Over/under clocking?

I'd rather have put these question in a comment.

  • This hasn't always happened. It started a couple weeks ago with a windows update. I don't know which. Memtest passes just fine. – user798080 Nov 15 '14 at 17:39
  • I had an update 2-3 weeks ago that failed and ran a restore point to get around it. This week's patch Tuesday went off without a hitch. Personally, I would go with a restore point first. If that didn't work, I'd look at an intermittent mem fault. I'd pull half of my memory and see if that fixed it. If it didn't, I'd replace it with the other half. Also, I'd cut my pagefile down to 2 gig and NOT let Windows manage it. From your usage prints, you only need a pagefile for crash-dumps. – Billy_Bob Nov 15 '14 at 18:57
  • And Your "Hard Faults" seem very high. That's a pagefile issue. – Billy_Bob Nov 15 '14 at 19:08
  • if it's a pagefile issue, what should be done? I already have a 32gb pagefile. – user798080 Nov 15 '14 at 21:29
  • I think the hard faults reflect your problem and don't change what I have already suggested to do. – Billy_Bob Nov 16 '14 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.