I'm having this problem with my Toshiba L875-S7308 where I cannot boot my USB while in UEFI mode.

I have formatted the USB (tried MBR and GPT - same result), and restored the ISO using the Windows 7 USB/DVD Download Tool. When I try booting the USB, the laptop simply ignores it and continues booting Windows. I have tried changing the boot order, or manually selecting the USB with no positive result. It seems like it's not even recognizing it (it's not showing the USB's name in the boot menu).

However, when I try booting in CSM boot mode, the USB boots just fine. I tried installing Windows 10 in CSM then setting the boot mode back to UEFI mode, but I can't. I'm trying to dual-boot Windows 10 with Windows 8.1 (already installed) and I'm currently using GPT, so I need to format the drive to MBR but I don't want to go through that trouble.

I made sure that Fast Boot and Secure Boot are both disabled.

Any help would be greatly appreciated.

  • I suspect the tool you are using honestly. Have you tried any other tools for this job?
    – Ramhound
    Nov 15, 2014 at 19:03
  • @Ramhound I tried manually copying the files and the tool mentioned above. Same result in UEFI.
    – Moe
    Nov 15, 2014 at 19:31

6 Answers 6


Two important points:

1: The Windows 7 USB/DVD Download Tool is not compatible with USB 3.0. To create a USB stick that is compatible with USB 3.0 using the native boot experience of the Windows 10 Technical Preview media (or Windows 8/Windows 8.1), use DiskPart to format the USB stick and set the partition to active, then copy all of the files from inside the ISO to the USB stick.

2: UEFI (CSM disabled) requires the USB stick to be formatted FAT32. If your stick is formatted NTFS, it would explain the behavior you have described.

  • 2
    Thank you! I have been using NTFS for my installer stick not knowing it's supposed to be formated as FAT32. Thanks again!
    – Moe
    Dec 24, 2014 at 10:15
  • 1
    Hi. I'm currently running windows 7 ultimate x86. I created a bootable USB of Windows 10 PRO x64 using Power ISO under FAT32 file system. I'm still facing the problem of not having the USB booted from. My machine is x64 compatible. I've used x64 OS before but am having trouble in this case. Can you please help me? Thanks. Mar 29, 2016 at 5:41
  • 1
    I have a USB 3.0 stick that is formatted NTFS that I use to boot in UEFI mode. It's NTFS because I'm using files larger than 4 GB. Jun 24, 2016 at 20:18

You will be able to boot in by using Rufus.

  1. Prepare the usb device in Rufus. Select GPT for UEFI only. Select FAT32. UEFI specs define FAT32 as mandatory. (Source)
  2. Set your bios to default settings. (This enables all uefi options and secure boot)

You can now install windows 10 in uefi mode.

  • 2
    Since many Windows ISOs are larger than 4 GB, FAT32 is probably not advisable. Jun 24, 2016 at 20:12
  • 6
    But the whole 4.somethingGB iso isn't copied as a whole onto the USB stick. Lots of kinda small files from within that ISO are, which I don't think any are over 4GB. So using FAT32 should be fine.
    – Mint
    Sep 21, 2016 at 19:24
  • 1
    @benJephunneh The wim file (windows installer media, or something) is the largest file, and is only 3.3gb.
    – Hellreaver
    Oct 19, 2016 at 0:51
  • 1
    @Mint That depends. Some USB installers -- like WinSetupFromUSB -- extract the iso and put the individual files on the stick, so FAT32 FS has no issues, as you're saying. Others allow you to simply place entire ISOs onto the stick, and the ISO is mounted as a disk, on boot. I have ISOs on my installation disk that are greater than 8 GB, which wouldn't be possible with FAT32. Oct 21, 2016 at 20:06
  • 1
    @AliTou, the answer is true regarding UEFI, but irrelevant since there is a way around the problem with the right tool (I call it a problem because I like to have multiple Windows and Linux installers, Clonezilla, +BCDs, on one USB stick that I can select from at boot). Easy2Boot is one such tool that makes the problem disappear, and which is a fine tool, anyway, although WinSetupFromUSB will accomplish similar things with a FAT FS. NTFS is faster, though, which is why I prefer it. Rufus is good only if nothing bad happens, so it's not good. Jul 15, 2019 at 17:37

Many of the hurdles that you might face when making a Windows installation USB drive are overcome with the right tool. The most versatile one at the moment is Easy2Boot. By following one of the tutorials out there, you can keep your USB drive (even large USB hard drives) formatted as NTFS, rather than limiting your options with FAT32. Even UEFI is possible. In my case, I have an NTFS-formatted USB 3.0 stick that I use to boot multiple installation ISOs in UEFI mode, and some ISOs are larger than 4 GB, which isn't possible with FAT32 formatting.

  • 1
    Only somebody without experience would down-vote this answer. Try it for yourself, if you think I'm pulling your leg. FAT32 is unnecessary, even for UEFI. Once more, my USB installation sticks are formatted as NTFS, and the ISOs are not extracted. They exist on the drive as ISOs, and the ISOs get extracted at boot. If you think I'm wrong, say something. It's pretty easy to look into Easy2Boot. If you're on this page, your Internet clearly isn't broken, so go there and see for yourself. Oct 21, 2016 at 20:15
  • Hmm, yeah not sure why 2 people downvoted you without a comment... I upvoted you so you're at a nice 0 now. I never know you could store multiple ISOs on one USB and choose from them, would have been really helpful in the past, so big thanks!
    – Mint
    Oct 22, 2016 at 22:55
  • 1
    Yeah, man. Just trying to help folks out. I spent years doing it the hard way, and knowing about the better tools coming out, these days, just makes it a breeze. Oct 28, 2016 at 16:42

If the ISO is > than 4 Gb, rufus will use NTFS. So, in order to boot

  • disable secure boot in the bios
  • press f9 to change boot order
  • select your usb
  • Logged in specifically to upvote: the USB 3 port thing was what did it for me. To be honest, it sounded random internet nonsense... but it works!
    – tijmenvdk
    Oct 27, 2021 at 21:05

Rufus is an excellent tool to build a bootable USB with. It's not signed digitally, however, so you have to disable Secure Boot. (Source: explanation why GPL3 files are never digitally signed). The default settings in Rufus are fine, but for UEFI in non-mixed mode the Partition Scheme should be GPT.

Sometimes the Select/Download button functions a bit flaky in that the Open Dialog will sometimes not recognise an .iso file when selected. The trick is to copy the full path to the iso file in the File Name field. (Source:a description of and solution to the problem of Rufus not being able to recognise iso files)

Regarding the problem of OP, even if the BIOS has UEFI and legacy sources enabled (i.e. mixed mode) and Secure Boot disabled, Windows will still install fine from the USB disk on a GPT style drive. (I've just done and verified this myself).

Rufus screenshot with GPT setting

  • You're wrong. It isn't the software package of the image tool that must be signed, but the image of the boot disk. I use Rufus regularly to create bootable images that can indeed be booted on systems with Secure Boot enabled. Feb 23, 2021 at 2:35
  • @music2myear You're right, of course. I should have proof-read my text better. It's the bootloader written to the USB flashdrive that's not digitally signed. Thanks for pointing it out! Mar 19, 2021 at 13:33

Disabled secure boot and UEFI mode and in legacy mode select first bootable device USB device or DVD and restart the system. Now you can install windows easily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .