0

My Sony Vaio laptop with Windows 2007 installation doesn't connect to internet on Wifi. It used to work all this while (last few years) but this problem started a few weeks back. It works fine when it's on hard wired network. On Wifi, it shows that it's connected to local network but it actually fails to connect to internet.

I have already gone through tons of troubleshooting instruction from Sony Support pages (https://us.en.kb.sony.com/app/answers/detail/a_id/41882/~/how-to-troubleshoot-a-wireless-lan-connection-issue.) and internet but I haven't been successful to fix this.

Laptop Details:

  • Sony Vaio Model: VPCEB26GM
  • Operating System: Windows 2007
  • Network Adapter: Intel(R) Centrino(R) Advances-N 6200 AGN
0

I tried all the possible options to troubeshoot Sony Vaio issue, most of them listed here: http://www.pcworld.com/article/260524/how_to_fix_your_wi_fi_network_7_tips.html

But nothing worked. However when I took my laptop to my work, the WiFI worked fine. So I figured it has to be some problem on my Internet Provider side even though all of my other devices worked fine. I called my ISP and they had to reset my internet settings on their side which fixed the problem of Wifi connectivity. As a reasoning they mentioned that Sony Vaio has a tendency to have Wifi issues when they are moved from one ISP to another in some cases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.