0

When I drag-and-drop to create a shortcut to the page I'm viewing - all I get is a generic white icon:

enter image description here

  1. I've uninstalled and reinstalled Firefox.
  2. I've removed the user folder.
  3. I've tried running in safe mode.
  4. I've tried disabling the firewall.
  5. I've set browser.shell.shortcutFavicons to false (that made all icons be the generic Firefox-link icon).

Any more ideas?

1

Same thing from version 31 up. I installed version from 32 to 33.1.1 on 3 pc's ! same thing... url shortcut blank icon. I did everything.... including those 5 steps that you did. For me working well with 31 version. Best from me!

0

It's the new version. Firefox 32 is fine in this respect.

(Might be a security risk, though.)

-1

The problem is two-fold with this [stupid] behavior.

First, Firefox creates a Windows shortcut and references the cruddy icon in it's shortcutCache which renders as a tiny, ugly smudge. If you delete the cache or reinstall Firefox, then all your shortcuts are broken.

Second, the about:config setting to disable this awful behavior doesn't work either.

Until someone wakes up and finally fixes these annoying bugs, you will have to edit the shortcuts. They are just text files, so you can go into Notepad and delete the IconFile line.

Next problem is, then, that Windows caches icons for performance, so you will have to rename the shortcut. Deleting the Windows icon caches is too much of a pain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.