4

I installed CentoOS 7.0 1406 on a VMWare ESXi 5.5 hypervisor. I installed "Sever with GUI" and selected KDE. However on boot I get the following messages in under a second, before the process tops (waited 15 mins, multiple times):

sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Assuming drive cache: write through

With a flashing "_" but no ability to provide input.

The drive is encrypted. I do not know if CentOS's drive encryption would affect this (I haven't been given the ability to enter the phrase to decrypt the drive yet)

I tried reinstalling it from scratch, same error messages. I have a Windows 2012 server running on the hypervisor with no issues. I Googled around, and this doesn't appear to be an issue with CentOS in general, so I imagine it's some way that I configured my virtual machine, or installed the OS.

I'm running on 2 GB of RAM and 1 virtual core. I tried booting up with removing the vm's access to the network, and this changed nothing.

  1. What is the issue?

  2. What can I do to troubleshoot the current install/virtual machine?

  3. How could I resetup the virtual machine, and reinstall the OS to avoid this issue in the future?

6

At the GRUB boot menu, press e to edit the boot config and remove rhgb.

Edit: You can disable it permanently by removing rhgb in /etc/default/grub and execute grub2-mkconfig -o /boot/grub2/grub.cfg to update your boot grub.cfg.

3
  • 1
    Can you explain why this works? I find it only happens when running disk encryption. – blacklight Apr 12 '15 at 1:04
  • 1
    plymouth isnt working correctly, its supposed to give you a gui where you can enter a password instead of a blank screen. So by disabling rhgb (redhat graphical boot) you get an alternative way of entering your password. – laapsaap Apr 15 '15 at 22:20
  • hi, any idea what command that i should type in grub> prompt? sorry i'm newbie to centos here *i'm using centos 7 – AnD Nov 6 '15 at 1:38
1

At the grub prompt, hi 'e' to edit the parameters. Remove rhgb quiet from the kernel parameters. It's a known bug.

0

So I tried doing a fresh install without drive encryption and it appears to be working just fine.

0

Download a newer version of the CentOS installation media and re-install. This problem seems to affect CentOS 7 systems from 2014. I experienced this problem installing a system from CentOS-7.0-1406-x86_64-Minimal.iso. I downloaded the latest ISO (which is CentOS-7-x86_64-Minimal-1511.iso as of this writing) and the problem disappeared. The server was able to mount encrypted volumes on boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.