I'm trying to install R on RHEL 7. I'm using epel-release-7-2.noarch.rpm and resolved many dependencies (one by one by manual .rpm installation) but at the end of the dependency resolution I got these errors:

--> Finished Dependency Resolution Error: Package: R-core-3.1.1-7.el7.x86_64 (epel) Requires: tex(dvips) Error: Package: R-core-devel-3.1.1-7.el7.x86_64 (epel) Requires: texinfo-tex Error: Package: R-java-devel-3.1.1-7.el7.x86_64 (epel) Requires: java-devel Error: Package: R-core-3.1.1-7.el7.x86_64 (epel) Requires: tex(latex) Error: Package: R-core-devel-3.1.1-7.el7.x86_64 (epel) Requires: tex(latex) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

I'm using a system not registered to Red Hat Subscription Management, so I can't use subscription-manager to register it and resolving dependencies.

Where can I find tex(dvips) and tex(latex)? I'm trying to download it from mirror.centos.org/centos/7/os/x86_64/Packages/ but I still haven't found the correct files

Update: Finally I've resolved myself the problem updating the RHEL repo: cd /etc/yum.repos.d/ vi CentOS-base.repo [base] name=CentOS-$releasever – Base baseurl=http://buildlogs.centos.org/centos/7/os/x86_64-20140704-1/ gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7 priority=1 exclude=php mysql

And after that: yum update yum install texlive yum install R

...and a clean installation done! :)

  • 1
    if you solved the problem is valid to post your own answer and mark it as the right one Jul 10, 2015 at 11:10
  • Do you know how can I check what's the newest available version of R for RHEL 7? Sep 16, 2015 at 14:44

5 Answers 5


I think installing R on CentOS 7 is simplest this way:

sudo yum install -y epel-release 
sudo yum update -y 
sudo yum install -y R
  • I think the premise of the question was that the OP was having dependency problems even though he was using epel-release. May 10, 2018 at 22:13

If you do not wish to install the CentOS repos, you can hand pick the individual packages that are required:


 [ec2-user ~]$ cat /etc/redhat-release
 Red Hat Enterprise Linux Server release 7.3 (Maipo)

IMPORTANT: Verify that EPEL repo was installed and configured as expected. However, when installing R, there are still dependency problems:

[ec2-user ~]$ sudo yum install R
… output truncated …
--> Finished Dependency Resolution
Error: Package: R-core-devel-3.3.1-2.el7.x86_64 (epel)
       Requires: texinfo-tex

There is no package for this in the Redhat or EPEL repositories. I grabbed one from CentOS7 repo.

[ec2-user ~]$ wget http://mirror.centos.org/centos/7/os/x86_64/Packages/texinfo-tex-5.1-4.el7.x86_64.rpm

And tried to install that but got another dependency problem…

[ec2-user ~]$ sudo yum localinstall texinfo-tex-5.1-4.el7.x86_64.rpm
… output truncated …
--> Finished Dependency Resolution
Error: Package: texinfo-tex-5.1-4.el7.x86_64 (/texinfo-tex-5.1-4.el7.x86_64)
       Requires: tex(epsf.tex)

Again, nothing in EPEL or RedHat, so I grabbed another couple of CentOS7 packages:

[ec2-user ~]$ wget http://mirror.centos.org/centos/7/os/x86_64/Packages/texlive-epsf-doc-svn21461.2.7.4-38.el7.noarch.rpm
[ec2-user ~]$ wget http://mirror.centos.org/centos/7/os/x86_64/Packages/texlive-epsf-svn21461.2.7.4-38.el7.noarch.rpm

So now I install the downloaded local packages

[ec2-user ~]$ sudo yum localinstall texlive-epsf-doc-svn21461.2.7.4-38.el7.noarch.rpm
[ec2-user ~]$ sudo yum localinstall texlive-epsf-svn21461.2.7.4-38.el7.noarch.rpm
[ec2-user ~]$ sudo yum localinstall texinfo-tex-5.1-4.el7.x86_64.rpm

And finally…

[ec2-user ~]$ sudo yum install R
…output truncated…



BTW: to the ones who have a subscription and want to stay on the RHEL repositories therefore, will find the missing packages in "rhel-7-server-optional-rpms".

So yum --enablerepo=epel --enablerepo="rhel-7-server-optional-rpms" install R worked for me.

You might have to do a subscription-manager repos --enable rhel-7-server-optional-rpms.


For those looking for a straight answer, R belongs to RHEL Extra Packages for Enterprise Linux (EPEL), therefore:

su -c 'rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm'

sudo yum update

sudo yum install R

If you are installing on Redhat, you just need to local install 'textinfo-tex' and 'textlive-epsf-svn' from CentOS repo, and then install R from epel replease repo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.