Can somebody tell me why I cannot get any sound with most of KDE 4?

I'm running a Gentoo box, I'm in both the 'audio' and 'video' groups. I can get sound with mplayer ( but not smplayer ) Firefox and Skype but nothing else. I can't get the test sound to play from the settings window, but Phonon is not whining about broken sound cards when I start up.

I have checked with kmix, we seem to be completely unmuted ( and I can get sound with some apps)


Try going to the Backend tab and see which is the top preferred selection, and perhaps change it to prefer one over the other. For good measure may as well re-compile media-sound/phonon and all it's audio-related deps while you're at it.

All those other apps don't give a hoot about Phonon, so that's why they work.

For reference, I also run a Gentoo desktop w/ KDE4 (4.3.4) and set xine as my preferred backend with GStreamer as second. I never had a problem with mine, and have been "emerge -uD world"-ing since 2008.0

|improve this answer|||||
  • Sadly, that's not the answer. It might have been the answer for someone else... :-) – user4774 Jan 8 '10 at 11:42
  • try using phonon-mplayer (mplayer backedn for phonon). maybe it works. – Capi Etheriel Apr 29 '10 at 1:58

Removing the ~/.pulse and ~/.pulse-cookie files fixed this mess for me.

Opening System Settings -> Multimedia recreated them, so I suppose the older ones were messed up after an upgrade of the KDE/Qt packages.

|improve this answer|||||

For me the issue is a combination of suck: phonon and pulseaudio. Try deleting the pulseaudio settings in your home dir. Maybe reboot. I forget what happened to fix it but I haven't been having the problem too much lately. However I still get errors like that every once in awhile. I use Debian/Lenny and Ubuntu 9.10.

Maybe someday Linux will get a stable sound system. One would think that it would be a solved problem by now...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.