1

I have a Digital Ocean droplet running CentOS release 6.6 and I need to install Ruby and Capistrano on it. I've been following this idiot's guide;

https://www.digitalocean.com/community/tutorials/how-to-use-capistrano-to-automate-deployments-getting-started

but I've run into a problem at the command rvm install 2.1.0.

Basically the install script tries to install the package libffi-devel but cannot. Throws an error saying there's a Multilib version problem I need to resolve and suggesting some remedies. None of them seem to work and either I'm Googling the totally wrong things or this doesn't happen all that often as I cannot find a solution. Here's the screenshot;

enter image description here

What have I tried;

  1. Yum check runs (takes ages but gets there eventually) and just returns;

    Loaded plugins: fastestmirror
    check all
    
  2. I've tried rerunning the command with the flag --setopt=protected_multilib=false as it suggests (or suggest not to do, I was desperate). I'm not sure what I'm doing wrong there syntactically but that throws the error;

    Unrecognized command line flag: '--setopt=protected_multilib=false' ( see: 'rvm usage' )
    
  3. By trying the command yum list libffi it shows me the following (image below). Namely that there is an installed package and an available package. If I try to upgrade the installed package with yum update libffi.x86_64 it tells me No Packages marked for Update. If I try to remove the uninstalled package using yum remove libffi.i686 it tells me Package(s) libffi.i686 available, but not installed. No Packages marked for removal.

enter image description here

  1. Updating everything with yum update, it tells me No Packages marked for Update.
1

Well I got it sorted. I was hesitant to use the answer in this Stack;

https://stackoverflow.com/questions/15799047/trying-to-remove-yum-which-is-protected-in-centos

As there were comments suggesting yum itself ended up broken. I tried it anyway;

rpm -e --nodeps libffi

And it uninstalled the offending libffi package. Then

yum install libffi-devel

worked fine and I could carry on and install ruby no problem.

  • 1
    Just want say that I had the same problems and your suggestion worked fine. But I feel quite uncomfortable deleting a package that yum depends on. Maybe someone can suggest a safer solution or explain, why this is not as dangerous as it sounds. – Sascha Jun 16 '15 at 12:04
  • @Sascha - I totally agree. Felt like a right dirty way to do things, be great if somebody gives a nice clean answer to this question! – McNab Jun 17 '15 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.