Whenever I delete a track from my system, GNOME Music keeps it in my library. How do I refresh GNOME Music so it removes them from my library?

This problem doesn't seem to occur for mp3 tracks that don't have tags.


Use the GUI utility tracker-preferences to update relevant information.

gnome-music uses tracker to find your music. The easiest way to interact with tracker is through the tracker-preferences utility. From there, you can tell tracker to index certain directories. This means we can solve the issue by "un-indexing" and "re-indexing" whatever directory holds your music.

  1. Install tracker-preferences. This may be as simple as sudo dnf install tracker-preferences, or sudo apt-get install tracker-ui, or you may have to figure out how to install it on your machine.
  2. Open tracker-preferences either at the command line or through your applications menu.
  3. Under the Locations tab, find the directory listing that has your music, e.g. /home/username/Music. Un-check the radial button for Recurse on that directory. Click the Apply button. Re-check the radial for Recurse on the directory. Click the Apply button again. Wait for the tracker database to update. (There's no output or loading bar or anything, just give it a minute or two to work in the background.)
  4. Open gnome-music either from the command line or from your applications menu. If tracker has been able to update, your library should reflect the changes.

I know this is more of a "sledgehammer" solution than I would prefer, but it's the only thing I've found to work. Please feel free to update with other suggestions or workarounds.


  1. "How to solve gnome-music “no music” issue on Fedora 20"
  2. man tracker & tracker daemon help and other help pages
  • is there any specific command for tracker to update the tracker database? – Hendra Anggrian Apr 26 '16 at 9:47
  • 2017: the package is called tracker-gui on ubuntu – Epskampie Jun 1 '17 at 12:39
tracker index -m audio

Seems to work for me, but not sure if it is effected by the earlier clearing. However the manual says that -m is to RE-index the mime parameter.

tracker status

will tell you when the process has finished, have about 3k music files in the assigned folder and it took about 4 minutes for the gnome-music albums and library to update.


tracker daemon -t (terminate tracker daemons)

followed by

tracker daemon -s (start tracker daemons)

does the trick for me. Use tracker status to see how many files are added. If it doesn't work you might use tracker reset --hard first, this will delete the tracker index.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.