3

Loading Full size image

I'm running Windows XP as guest on VMware Player 6.0.1, but I'm getting a black screen. The VM starts up, I see the XP logo screen as it loads, but then the welcome screen never appears.

Black screen Full size image

It's worth noting that this VM is running inside another VM running a Windows XP guest; the outer-host is Windows 8. Everything is responsive, I can move the innermost-machine window around, even resize it, but it won't display the welcome screen.

Repsonsive, and resizable Full size image

According to ( Ubuntu 11.04 VM shows a black screen in VMware Player ) and ( Issue while loading vmware fusion 3.0 ), enabling hardware graphics acceleration may fix black-screen issues for some guests, but my VMs already have it enabled, and my screen doesn't start black, it goes black, so I don't think it's the same issue. I've also looked at ( Get black screen at logon/welcome? ), but as I've shown in my screenshot, adjusting the screen resolution of the guest doesn't help.

What is the problem here, and if it's fixable, how so?

Please, no harsh-comments along the lines of "don't run a VM in a VM!!!". I'm aware it's not a recommended activity, this is just for fun.

4

In the Virtual Machine Settings of the guest that is blank, under Hardware, Display, try turning off Accelerate 3D graphics.

When I have the box on, under Linux Mint 16 (ubuntu), the guest will be black on every screen except the main screen--unless I turn off the 3D acceleration as noted above.

0

Why do VMWare virtual machines stay on a black screen on start?

When starting a VM, VMWare will try to connect to this address (which is localhost in IPv6 format on ports like 11527 or 11535 etc.):

vmware.exe - [::1]:11535 (IPv6)

This is needed for the VMs to work, I don't know what it is, but I just know that my VPN, and one other time, my proxy, were blocking vmware from establishing this connection, thus I was getting the black screen issue.

Proxifier

So I turned off the VPN, and in the second case which I was using Proxifier, I added a rule inside the Proxifier program to direct all vmware.exe connections (not route them to proxy server), and the problem was resolved.

Issue also reported and discussed here: https://communities.vmware.com/thread/454006

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.