1

Since yesterday the Sublime Text 3 tabs appear fine (but lower in height) at first and then appear garbled after I close a tab.

Here's a cropped screenshot showing the issue:

enter image description here

I am using the Brogrammer theme and haven't changed the configuration recently. The only event that would make any remote sense as a cause was me undocking the laptop and thereby detaching the dual screen setup, returning to the builtin laptop screen. However, this didn't cause issues before.

Since this issue is now persistent, I'd like to "reset" Sublime Text to a state as if the theme was freshly installed. How can I pull that off?

I am using Sublime Text 3, build 3065 on Windows 7. However, I'm confident if you give instructions for another OS I'll be able to follow.


I tried purging the Cache folder under %LOCALAPPDATA%\Sublime Text 3, but to no avail.

Also, if multiple tabs get opened at once, all but the focused tab will appear garbled.

Worse yet: the Command Palette (Ctrl+Shift+P) is nearly invisible on the background. I though I could disable or uninstall the theme this way. See:

enter image description here

  • I have this too. Last time I had to completely reinstall sublime. I was using a custom theme (Seti UI) at the time. – evolutionxbox Nov 20 '14 at 21:42
1

Open Preferences -> Settings-User and look in the "ignored_packages" list to see if your theme is listed there (I bet it is). Simply delete the package's name from the list (and the names of any other plugins that might be there that you haven't specifically placed there), save the file, restart Sublime, and you should be all set.

This happens sometimes during Package Control's update process. Plugins/packages to be updated (Brogrammer had a new version released yesterday) are placed in the "ignored_packages" list right when Sublime starts up. The package is then upgraded, and is supposed to be removed from "ignored_packages". However, for whatever reason, this occasionally doesn't happen. For normal plugins you just notice that the plugin stops working, for themes you get the visual effects that you are seeing now.

|improve this answer|||||
1

Check to see if your preferences are trying to load a theme which doesn't exist.

I just made a fresh installation of Sublime Text 3 on a new Debian 9 VM and was having this same issue, so I installed Sublime Text 2 which I was more familiar with, but it was having the same issue too. I finally figured out that the problem was that I had copypasta'd my old preferences which included a definition for a theme which didn't exist on the new system, so the program didn't know where the UI graphics were, hence all the garbage graphics.

I would also recommend that you check your file paths and make sure the graphics haven't somehow gone missing or had a change in read permissions.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.