2

Amazon includes clamav-0.98.4 in its AMI version 2014.09.1 so I installed it and gave it a try on one of my EC2 instances.

After updating the definitions with freshclam, I've performed a scan with ClamAV using this command:

clamscan / -ir \
    --exclude-dir=^/sys \
    --exclude-dir=^/dev \
    --exclude-dir=^/proc \
    --scan-mail=yes

After completion, this is the output:

----------- SCAN SUMMARY -----------
Known viruses: 3685614
Engine version: 0.98.4
Scanned directories: 23438
Scanned files: 223072
Infected files: 0
Total errors: 2
Data scanned: 6812.04 MB
Data read: 43300.34 MB (ratio 0.16:1)
Time: 2333.526 sec (38 m 53 s)

It shows I have 0 infected files, but 2 errors. I'd like to see these errors, but they aren't present in the output.

I started reading the man pages and tried running the command again, but now with the --verbose option added to it. The output was exactly the same, except it was preceded by thousands of lines like this:

Scanning /usr/bin/symlinks
Scanning /usr/bin/package-cleanup
Scanning /usr/bin/unzipsfx
Scanning /usr/bin/gpg-agent

And so on.

After this I tried adding the --log=/var/log/clamscan.log option, to make clamscan write to a log file. Opening this file after it had finished running just showed me the same as the output on the command line.

I can't seem to find out what these errors it has found exactly are. Is there any way to figure this out? Or better yet, have clamscan include this in the log file?

1
  • I have the same problem @ClamAV, can't find any way to produce a useful report... Apr 5, 2019 at 14:10

0

You must log in to answer this question.

Browse other questions tagged .