0

I'm attempting to resize my virtualbox VMDK via this answer on SO. The original size is 75GB and I'm trying to double it.

Step 1 goes fine, I am able to convert my vmdk to a vdi. I attempt to resize the VDI and I get that VDI isn't supported.

It is a dynamically sized disk, so my first thought was that I was making its maximum size too big for the hard drive that it was on. I made some space, and got about 110 GB free on the drive. I tried again with resizing it to 100,000 MB (previously I was attempting 153,600) still no luck.

I am using the exact commands in the linked answer. I have a backup, so I'm not worried about data loss.

The exact command I am using:

.\VboxManage.exe modifyhd 'F:\Path\to\file' --resize 100000

After looking at a few other threads (Resizing virtualbox vdi doesn't work, How to resize VirtualBox disk?, Increase dynamic VDI disk size) I've had no luck. My machine is not currently using snapshots.

I am using Windows 8.1, virtualbox 4.3.10r93012 and the guest is windows 7.

Edit: I've attempted it in Xubuntu 14.04 with 4.3.10_Ubuntur93012 (looks to be the same version packaged differently).

EDIT: It appears that this cloned VDI is not in fact a VDI (emphasis mine):

/media/mitch/636E95045173F28F/Virtualbox VM$ vboxmanage showhdinfo clone.vdi 
UUID:           822d8b5f-47eb-4204-842a-a88abd014fa3
Parent UUID:    base
State:          created
Type:           normal (base)
Location:       /media/mitch/636E95045173F28F/Virtualbox VM/clone.vdi
**Storage format: VMDK**
Format variant: dynamic default
Capacity:       76800 MBytes
Size on disk:   61404 MBytes

vs the actual vmdk (some size difference, as I've been using it:

mitch@mitch-acer:/media/mitch/636E95045173F28F/Virtualbox VM$ vboxmanage showhdinfo backup\ 11-20-2014/Windows\ 7\ x64.vmdk 
UUID:           6d2ad88f-1fda-4611-85a2-caab442f3530
Parent UUID:    base
State:          locked write
Type:           normal (base)
Location:       /media/mitch/636E95045173F28F/Virtualbox VM/backup 11-20-2014/Windows 7 x64.vmdk
Storage format: VMDK
Format variant: dynamic default
Capacity:       76800 MBytes
Size on disk:   61566 MBytes
In use by VMs:  Dev env (UUID: 1d87ed9d-87e5-4587-84ba-ec322665c1b4)
  • I believe that you can't enter a size that is smaller than the current size – vembutech Nov 20 '14 at 22:14
  • It's larger. I'm attempting to double it – Mitch Nov 21 '14 at 13:52
0

The answer, at least in my particular case is that I made the VM with VMWare (I'd forgotten that fact) but I've used it with virtualbox for months. It seems to me that VBox can't convert a vmdk made by vmware to a vdi properly.

The output of file on the cloned vdi was : clone.vdi: VMware4 disk image which is what made me remember that I made it that way. Using VMware's resize functionality on the original (and the clone!) seems to have worked.

I'm going to not mark this as the answer for now, hoping for an answer to the general case problem from someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.