0

From my xubuntu I dont have internet access and it seems like all requests to my subnet (192.168.0.1, 192.168.0.2, . . . .etc) are directed to me.

I have an apache server installed, so when I open me browser and type for instance 192.168.0.1(router address), 192.168.0.2, or whatever , I always get that one page from apache.

Other IPs or addresses are not resolved.

It happens only with my router.

It does not happen from my windows

(It feels like a conspiracy of xubuntu and my router)

I havent done anything radical with the hosts and interfaces files. I restored them and the problem remains.

Any experts suggestions?

edit: it seems like it happens even when networking is disabled.

these are my interfaces and hosts files (I think it might got something to do with it)

interfaces:

auto lo
iface lo inet loopback

hosts:

127.0.0.1   localhost
127.0.1.1   gil-Spectre

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
0

Well, I m definitely not a super user. I solved it eventually by resetting the router(turn off and on again) but I don't understand how this issue was solved.

I would be glad if someone could give me an explanation. I would like to be able to reproduce this behavior and to solve it.

Edit: I found out that restarting the networking service is not enough for the new settings to take effect in Xubuntu 14.04, I had to reboot. It confused me allot because I didn't see why the valid settings aren't working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.