8

I tried installing this script but then got this error message:

enter image description here

I'm hoping for an answer that's similar to this one but for python instead of ruby.

16

There is no way to install Python plugin in PHPStorm.

Please use IntelliJ IDEA Ultimate to employ all languages (JavaScript, Java, PHP, Python, Ruby, Scala, etc.) support in one environment. If you don't want to try IDEA and only need a basic syntax highlighting for Python files in PHPStorm, you can either create a new file type in Settings/File Types, add *.py as registered pattern there, and define your own syntax highlighting rules, or search for existing textmate bundles for Python files in the web, import them and use for the *.py syntax highlighting - see TextMate Bundles in PhpStorm and SO discussion for more info.

| improve this answer | |
  • 4
    Works fine with this textmate bundle. You can even choose a Darcula theme – mperrin Aug 11 '15 at 15:21
  • 1
    @mperrin It took me a minute to figure out how to get the theme to work. I followed the links that Iena provided, and downloaded the bundle you suggested. After getting the tm bundle installed, it did highlight my syntax, but it wouldn't recognize my current color scheme (Darcula). In order to get it to work, i had to uncheck the python bundle, apply the change, then select the color scheme i wanted, then recheck and re-apply to get it to take. Leaving this comment here in case someone else stumbles across this answer. – casper Jun 9 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.