0

I am upgrading Scientific Linux 6.3 to 6.6

I have to update machines of Scientific Linux 6.3 to 6.6. I tried #yum list updates and .# yum update

It downloaded some files and installed. But my Scientific Linux is still showing Scientific Linux 6.3.

.#yum list updates returns "Loaded plugins: refresh-packagekit,security".

Doing the same worked fine in Red Hat Linux.

2
  • You can always just use a disk to update your installation. – Ramhound Nov 21 '14 at 15:04
  • @Ramhound This is not correct in the current situation. One can not upgrade between major version but they can within minor releases. See my answer for more info. – user391035 Nov 22 '14 at 15:01
1

Install yum-cond-sl6x if it not available from

http://rpm.pbone.net/index.php3?stat=3&search=yum-conf-sl6x&srodzaj=3

follow rpm -ivh

.#yum clean all

.#yum update

1

For doing and update between point releases (e.g. 6.3 to 6.6) you simply have to run.

yum install yum-conf-sl6x

This is also documented in in the Scientific Linux FAQ

It does not not work if you want to Upgrade from one major (e.g. 6 to 7) version to another.

1

Make sure that the sl6x repo is enabled. Else 'yum update' will return nothing. You can enable it on demand with:

# yum --enablerepo=sl6x update
1
  • This is what I was missing. Without this repo the yum-conf-sl6x package was reported as already installed, but didn't update anything. – Quantum7 Jan 20 '20 at 11:03
0

Try the below commands and check.

yum clean all
yum update

Note : If you are having any issue after doing the same try stopping the yum process "yumpythonbackend" and refetching the repo files might help

1
  • Yes, I have already tried doing this and its still the same :( – user3025288 Nov 22 '14 at 12:44
0

Apparently yum-conf-sl6x is not a command, but a RPM.

Having installed it, I can only see one single file

etc/yum.repos.d/sl6x.repo

So one will then need to issue the command:

yum upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.