0

I hqve a set of Logitech X530 speakers which have 5 speakers and a sub. After moving apartment, I no longer have the two rear speakers, just front left, front right, center and the sub (they were wired into my apartment).

I have a Dell Alienware R3 with onboard sound and six outoputs (orange, green, pink, grey, blue and black). The sub has green, orange and black outputs. The green and orange are connected to their matching colours between the PC and subwoofer, but no matter where I plug in the black from the subwoofer, I have no sound from the front right channel. Is there a rule for what connects where?

0

Your PC's audio control panel will tell you what is connected where. It will also allow you to configure the operating mode (2.0, 2.1, 5.1, etc), though 3.1 is not usually an option.

It should also be able to generate test tones for each speaker.

It might be a good idea to swap the speakers around, to make sure that it's not the speaker or cable that isn't working.

  • I would swap the speakers, but the right hand one (the non functional) is the one with the volume knob which connects to the sub via an unremovable RS232 cable. The power light illuminates when I switch it on and the other speakers go 'through' it. I understand about 3.1 not being an option, but when I select 5.1 in the Realtek control panel and click each speaker to test, clicking the left and center plays sound through the left and center speakers. It's not like the center has become the new right, it hasn't and still works when testing the centre. – Echilon Nov 22 '14 at 18:44
  • I don't know what your sound card is. I have an on-board Realtek HD chip with three 3.5mm stereo sockets. Default 2-speaker configuration is stereo line out (L+R) on the green socket, with line in on the blue and microphone in on the pink. So the cable you need to swap is the green jack from the speakers: try plugging it into an MP3 player and see if you get both channels. If not then the fault is in the speaker system. If the right channel does work, then check the front balance slider on the audio control panel (you may have to scroll for this control). – AFH Nov 23 '14 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.