0

Running a Dell Latitude E7440 on EFI + SecureBoot + Windows 8.1 + BitLocker and I randomly get start-up issues where the OS is flagging iastora.sys as corrupt. With no action taken I can choose to continue to boot through to Windows and it works fine. It doesn't happen every boot, but when it does the SrtTrail.txt log file contains:

Root cause found:
---------------------------
Boot critical file c:\windows\system32\drivers\iastora.sys is corrupt.

Repair action: File repair
Result: Failed. Error code =  0x2
Time taken = 2188 ms

Any thoughts on what might be causing corruption? I have tried installing the latest chipset drivers and that has not resolved the situation.

3
  • Have you tried re-installing the IRST? Intels rapid storage technology drivers, which is mostly for raid, includes IaStoreA and IaStoreF, this is not usually included in the "chipset" drivers. – Psycogeek Nov 23 '14 at 21:57
  • @Psycogeek - yes, that was my first troubleshooting step. – Colin Bowern Nov 24 '14 at 22:21
  • oh so this is an ultrabook, so what driver is using that? it is beyond me , but this has occured to others when one driver set is used for install, and other parts and pieces that do not belong together are installed, but again they were doing raid. People not doing raid, uninstall the whole of RST to resolve rst failing issues. That is all I know, and searching the web for this problem is a mess. For me I specifically use raid, and one time i found it usefull to disable the Old one IaStoreV, i do not think that applies here, instead the AHCI thing, and making sure that is as it should be. – Psycogeek Nov 25 '14 at 1:25
0

Since you aren't likely really using RAID in the E7440, you can change the SATA Operation Mode in the BIOS.

System Configuration > SATA Operation.

Try changing this to AHCI to bypass Intel RST.

I will note that you CAN run RAID in these ultrabooks, if you have an mSATA drive and no WWAN card. You can free up the 2.5" drive bay and install a drive there. I am running two drives in mine, but not in RAID.

1
  • Already switched to AHCI - did not resolve the issue. – Colin Bowern Jan 26 '15 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.