1

The process I'm using is as follows:

  • Setup a repeated ping from one machine (that's already connected to the switch) to the IP address of a second machine.
  • Plug the second machine (which is powered on, etc) into the switch.
  • Time how long it takes for the ping to be successful.

When I use a Dell Powerconnect 5524, that time is consistently about 30 seconds. I managed to borrow another switch off a friend, and that time is consistently 4 seconds.

It may be the switch I borrowed is just a higher spec, but I'm hopeful that the 30 seconds is a kind of refresh rate/update rate that is configurable. I've had a look through the switch admin interface & user manual but I couldn't tell what I should be changing. Is anyone able to help me by directing me to the kinds of settings that I could modify?

Many thanks :)

1

If we are speaking about enterprise grade switches, usually this delay is caused by Spanning-tree protocol, which is used to ensure loop-free Layer2 topology. Legacy standard 802.1D has it's weakness in slow convergence. That's one of the reasons that Rapid Spanning-tree Protocol 802.1w was evolved from 802.1D.

There exist mechanisms for faster convergence where you set the port on a switch as a Edge port and this ports are immediately change state to forwarding. However keep in mind that these ports should be only at the end devices to ensure that there will be no loop in topology.

2
  • Thanks @phandox. Spanning Tree State: Enable. STP Operation Mode: Rapid STP. BPDU Handling: Filtering. Path Cost Default Values: Long. Bridge settings: Priority: 32768, Hello Time: 2 sec. All ports are set to RSTP.
    – James
    Nov 24 '14 at 12:22
  • Setting the ports to Fast links seems to have done it.
    – James
    Nov 24 '14 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.