I plugged in my external harddrive (which was formatted on my Mac into HFS+ journaled) to my Ubuntu desktop 9.04 64bit. I am not able to get the drive to mount with write capability, how do I do that? Right now all I'm getting is read access, I tried

sudo mount -t hfsplus /dev/sdf2 /media/"Portable HD"

but that still gave me only read access... ideas??

  • I feel like the answers to this question are far better, easier, and safer than the answers provided here. Commented May 31, 2019 at 18:04

5 Answers 5


You need to turn off the journaling if you want to write to it from Ubuntu. Ubuntu only has support for writing to non-journaled HFS+ volumes.

On your Mac:

  • Open Disk Utility under Applications -> Utilities
  • Select the volume to disable journaling on.
  • Choose Disable Journaling from the File menu. (On later Mac OS versions you'll have to hold down the option button when you click the File menu. Or if you like Apple+J)

Disabling journaling from HFS+ is still possible up to OS X Yosemite 10.10

  • 5
    Do note that "Disabling journaling on your main OS X partition is not recommended however as journaling is an important feature of any filesystem that can prevent damage and data loss" (help.ubuntu.com/community/hfsplus)
    – Hay
    Commented Nov 6, 2010 at 13:00
  • 1
    @Hay you can re-enable journaling. All it does is help the system recover faster in such an event (ie. abnormal shutdown). Not the end of the world.
    – user1931
    Commented Nov 6, 2010 at 16:15
  • 12
    No, that's not all journaling does. It also helps prevent filesystem corruption, which could be serious enough to only be fixable with a reformat. Commented Apr 27, 2011 at 4:26
  • 8
    in macos 10.6.8, in step 3, open the file menu with "option+alt" pressed
    – commonpike
    Commented Jun 10, 2012 at 17:29
  • 2
    @JohnT Could you please provide a source for the fact that "Ubuntu only has support for writing to non-journaled HFS+ volumes" please? I'm doing some research on HFS+ and it would be very useful. Thank you.
    – Kyle L
    Commented Jan 13, 2013 at 3:37

First, make sure that you have hfsprogs installed. Example installation command:

sudo apt-get install hfsprogs

Next, mount or remount the HFS+ drive; commands need to be as follows:

sudo mount -t hfsplus -o force,rw /dev/sdx# /media/mntpoint


sudo mount -t hfsplus -o remount,force,rw /dev/sdx# /mount/point

Finally, if the drive was improperly unmounted or has otherwise become partially corrupted run fsck.hfsplus (provided here by Jayson) as such:

sudo fsck.hfsplus /dev/sdx#
  • 9
    Thank you very much for providing a Linux only solution! ^_^
    – FCTW
    Commented May 31, 2012 at 20:22
  • 14
    I'm on Ubuntu 12.04, the remount command should be like this sudo mount -t hfsplus -o remount,force,rw /dev/sdx# /mount/point. Then must use root to read/write data.
    – Coc
    Commented Sep 15, 2012 at 10:31
  • 21
    Why is this not marked as the answer?
    – Jonathan H
    Commented Jun 8, 2013 at 9:15
  • 5
    @Digiground and @Coc both fail with mount: warning: /media/mount/point seems to be mounted read-only. on Ubuntu 13.04 with hfsprogs installed.
    – here
    Commented Dec 24, 2013 at 4:56
  • 3
    If the disk has a problem, it will stubbornly only mount read-only. Verify/repair disk in OSX using Disk Utility as fsck.hfplus won't run "because it's a journalled file system".
    – Greg Bell
    Commented Dec 3, 2015 at 0:04

You can enable writing to HFS+ in Linux even if you didn't disable journaling. In addition to hfsplus which you already have, you need to have hfsprogs installed:

sudo apt-get install hfsprogs

Then, use the -o rw,force option.

If the drive is not mounted yet:

sudo mount -o force /dev/sdX /your/mount/point

If the drive has been mounted automatically (as it should be on a desktop system like Ubuntu), add remount to enable write:

sudo mount -o remount,rw,force /mount/point


sudo mount -o remount,rw,force /dev/sdx

/mount/point would usually be something like /media/Your_drive_label. /dev/sdx is your HFS+ device (eg. /dev/sdb1).

Use mount -l to find which device is already mounted on which mount point.

If the Mac disk uses the newer Apple "Core Storage", you may also need to add a sizelimit=N option, as detailed in this answer.

Finally, you will still have the problem that you need to either be root to write to the drive, or use bindfs as shown in this answer.

  • 1
    from the answer of Digiground, do you not miss the rw part in the command?? I succeeded with his options.
    – meduz
    Commented Jan 26, 2012 at 12:44
  • @meduz: I did not need "rw" in Ubuntu 10.04. I seem to need it now in 12.04. So I have edited the reply to add it.
    – mivk
    Commented Aug 14, 2012 at 6:48
  • Does this need disabling journaling?
    – Makmeksum
    Commented Dec 16, 2019 at 6:08
  • @Makmeksum : No, this is the alternative if you cannot disable journaling and then re-enable it. And it's easier too.
    – mivk
    Commented Jun 21, 2020 at 15:03
  • 1
    @authentictech: if there is some strange bug in the driver, yes, it might damage the filesystem. Which is why it is mounted as read-only by default. But I have used this many times with many different HFS+ disks, and have not seen a problem. I just had to sudo chown -R $macuserid $Any_added_folder before unmounting (where in practice, $macuserid was usually 99; check the user:group of pre-existing files and folders).Or sudo chmod -R a+rwX $Any_new_or_modified_folder to just give write access to anyone.
    – mivk
    Commented Nov 6, 2021 at 20:07

Have you tried to match permissions?

By default, Mac OS X formats volumes in journaled HFS+ volumes. Journaling is a feature that improves data reliability, and unfortunately it makes HFS drives read-only in Linux.

To disable journaling, just boot into OS X and fire up Disk Utility. Click on your HFS partition, hold the Option key, and click File in the menu bar. A new option to Disable Journaling will come up in the menu. Click that, and reboot into Linux. You should have read and write access to your HFS partition—however, the permissions on your Mac user's home folder will prevent you from reading or writing those files. we just need to change our UID in one OS so that it matches the UID in the other. Unless you have a reason for choosing otherwise, we're going to change our Linux UID to match our OS X one, since it's a bit easier. By default, the first user in OS X has a UID of 501, but you can double check this by going into System Preferences in OS X, right-clicking on your user, and hitting Advanced Options. If your User ID is something different from 501, replace 501 with your other UID in the terminal commands below.

Boot into Linux (we're using Ubuntu in this example) and fire up the Terminal. First, we're going to add a temporary user, since we don't want to edit a user that we're currently logged into. So, run the following commands in the Terminal, hitting Enter after each one:

sudo useradd -d /home/tempuser -m -s /bin/bash -G admin tempuser

sudo passwd tempuser

Type in a new password for the temporary user when prompted. Reboot and log in as tempuser. Then, open up the Terminal and type in the following commands, once again hitting enter after each one (and replacing yourusername with your Linux user's username):

sudo usermod --uid 501 yourusername

sudo chown -R 501:yourusername /home/yourusername

This will change your Linux user's UID to 501 and fix your home folder permissions so that you still own them. Now, you should be able to read and write to both your Mac and Linux user's home folder, no matter what OS you're logged into.

You may also want to fix your login screen, since by default Ubuntu won't list users with a UID of less than 1000. To do this, just open a Terminal and run gksudo gedit /etc/login.defs and search for UID_MIN in the text file. Change that value from 1000 to 501, and when you reboot your user will be listed in the login screen.


  • 1
    great solution! you've just saved me a few hours :) the only thing to add is delete the tempuser --> sudo userdel tempuser
    – Feida Kila
    Commented Oct 31, 2011 at 23:12

Just in case this helps anyone in the future - if you're not even able to get the drive to mount in Read-Only mode, it might be because the drive uses Apple Core Storage, which is a wrapper around HFS+. See here:

Mounting HFS+ partition in Ubuntu

Mounting HFS+ partition on Arch Linux

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .