0

I am currently trying to install debian 7.7 on a second hand computer, and I get a complete freeze during the install process, always at the same step - updating mirrors, 38%. Here is what I tried to find the cause :

  • My ISO image is fine, I checked the SHA256
  • I Burned it on a CD and on two different USB keys, same result
  • I ran memtest+, the RAM looks fine
  • I tried to run with a single RAM module (tested both), just in case memtest got it wrong, same result
  • Just in case I waited two hours to see if the computer would unfreeze, it didn't
  • I ran badblocks for 16 hours, the 1TB HDD looks fine
  • I tried a 32bit install, same problem

My next move is to burn an installer from another distribution, just in case. Otherwise, I am stuck. Do you see anything else I could try to find the cause of the problem (and hopefully fix it) ?


28/11: I may have found the source of the problem.

The guy that gave me the computer told me he had troubles with the network - as DHCP worked, I assumed the problem was somehow related to his windows install. But a try at installing linux mint from the graphical installer gave me a hint : the installer stalled when downloading content.

It looks like the network interface is damaged - it works enough to run a DHCP request, but as soon as you start transferring content, it crashes. Right now the computer is in the hands of its new owner. I disabled the onboard ethernet controller and told him to buy a network card. He will tell me if it worked soon.

  • How long does it freeze for? Have you tried leaving it there for some time eg an hour? – Rsya Studios Nov 24 '14 at 21:35
  • I have not tried that. I usually try to switch tty, see the whole thing is frozen, and proceed to a hard reboot. Will try that, just in case. – tgirod Nov 25 '14 at 8:14
  • Okay, the answer to that is indefinitely. The thing stayed frozen for two hours before I pushed the button. – tgirod Nov 25 '14 at 15:36
  • If you have selected to use a network mirror during the installation (optional for CD/DVD installs, required for netboot images), you will be presented with a list of geographically nearby (and therefore hopefully fast) network mirrors, based upon your country selection earlier in the installation process. Choosing the offered default is usually fine. DId that happen in your case? – Rsya Studios Nov 27 '14 at 21:16
  • @RsyaStudios I think I found the cause of the problem. Thanks for your time. – tgirod Nov 28 '14 at 12:49
0

The problem was caused by the malfunctionning onboard LAN controller. It worked enough for DHCP to work, but as soon as serious data was transfered, it failed and took the complete system with it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.