Since I started to use 2 monitors with my MacBook Pro, the cursor on the second (pivot) screen is doubled - one cursor is normal arrow and under that is the second cursor which is changing (hand etc.) If I zoom the screen one cursor zoom but the other cursor remain the original size.

Does anyone know how to get rid of this? It’s kinda annoying because the cursor is always blinking on link, etc.

2 Answers 2


Switching the resolution between Scaled and Default for display worked for me (just switching between various scaled resolutions had no effect).

System Preferences: Displays


Shaking my mouse (moving my finger on the trackpad) really fast got rid of the second cursor for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.