2

Is it possible to turn V-sync off in Windows 10 for windowed games? It wasn't possible in Windows 8/8.1 so I had to downgrade to Windows 7 which in I could simply change the theme to Aero basic which has V-sync turned off.

I play most of the games in windowed/borderless mode, so graphic cards' application can't do anything about V-sync. (turn it off or on.) In Windows 8 you can't turn DWM off (Desktop Window Manager?) which keeps V-sync on all the time.

2
  • If its not possible in Windows 8.1 then its not possible in Windows 10 unless the feature was specifically added and it wasn't in this case.
    – Ramhound
    Nov 25 '14 at 11:51
  • from what I know VSync is impossible to turn ON in windowed mode. How did you come to the conclusion it's turned on? More people are actually asking how to enable VSync in Windowed Mode, because it's actually impossible to perform VSync in Windowed Mode (at least on Windows)
    – Gizmo
    Nov 25 '14 at 11:51
4

It is not possible to turn off V-sync in Windows 10 as it is used for core graphics gui. Since this is the case any game/application that is run in windowed mode (borderless or not) will also be run with V-sync. This used to not be the case with Windows 7 (with the basic Aero as you said) and prior versions but starting with Windows 8 it was always on for desktop. The only way to turn V-sync off would be to run in exclusive fullscreen and turn it off in game or force it off if you an ATI or NVIDIA gpu. I know some games there is no option and for some using an integrated card the option is also lacking which is a problem for some systems.

0

If you use desktops.exe, suspend winlogon.exe and kill the dwn.exe process, you can disable forced V-sync. But first desktop won't work and other desktops (not Win10 desktops - desktops created by desktops.exe) work with some bugs.

Also, I'm not sure that the windows will work fine with a suspended winlogon.exe.

-2

found out how, cause i have done this before go to \AppData\Local\Packages\Microsoft.MinecraftUWP_8wekyb3d8bbwe\LocalState\games\com.mojang\minecraftpe in your files and go into the 'options' file and then look for 'gfx_vsync' then set it to 0, that should fix the problem.

edit; in the case of minecraft

1
  • Game vsync settings do not override anything running in a window.
    – Ray
    Sep 16 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.