40

Recently I installed BitComet. Now when I click a torrent magnet link from chrome it opens with BitComet though I changed the settings of BitComet to not to be the default program to open magnet links. I couldn't find default magnet link settings in μTorrent. I want my default program to open magnet links to be μTorrent. I'm using Windows 8.1 and my browser is Chrome, I want to make the default program to open magnet links to be μTorrent.

1
  • 1
    I had to deselect the 'open magnet link' option in qTorrent - then Apply, then reselect it - and it fixed the issue.
    – niico
    Jul 23 '18 at 17:52
29

Open μTorrent. Go to preferences from options menu. Select general. Click the button Associate with torrent files. Your problem is over.

1
  • Wrong answer gets 29 upvotes. He said Magnet, not torrent.
    – SidedTech
    Apr 17 at 8:46
19
+50
  1. Press Win + R, type regedit and press OK.
  2. Browse to the following location:

    HKEY_CLASSES_ROOT\Magnet\shell\open\command
    
  3. Double-click the default location and change the data section to:

    "C:\Program Files (x86)\uTorrent\uTorrent.exe" "%L"
    
2
  • This answer also works for Transmission and in fact any other program given the right path, thanks!
    – cat
    Feb 20 '17 at 15:58
  • 1
    after last windows update this doesnt work anymore (it worked for changing from utorrent to qBittorrent), but now no magnetic links open Sep 25 '20 at 1:28
17

You need to change the "Handlers" setting inside the Chrome Settings.

Click the Chrome menu on the browser toolbar.

Select Settings > Show advanced settings.

In the "Privacy" section, click Content settings.

In the dialog that appears, find the “Handlers” section. Click Manage handlers.

Use the drop-down menu next to a listed protocol to select the web service that should be used by default.

P.S - This answer was for a pretty old version of Chrome. The settings have changed since then and I don't use Chrome anymore, so maybe try some of the other answers.

3
  • 1
    ?? This doesn't work the list is read-only? See: i.stack.imgur.com/SkkOU.png
    – Pacerier
    Nov 26 '16 at 7:06
  • 16
    The settings layout has recently changed to make everything even more difficult than it already was. There is no "Manage handlers" any more.
    – Ken Sharp
    Aug 11 '17 at 2:38
  • In macOS Catalina, using Chrome v86 and Transmission, the "Handlers" route did not work for me. However, opening Transmission, going into Preferences and then clicking the "Accept magnet links: [Set Default Application]" button worked! Chrome now offers to open magnet links in Transmission. yay! Nov 27 '20 at 20:50
3

Assuming you are talking about windows

Chrome uses the windows default handler for the filetypes. Just search for "Default Apps" in your start menu and change the association there, and chrome will then call the correct file.

Settings

I just did this on win10 for .torrent

3
  • This helped me to find the Default app per Protocol which was what I needed.
    – Machado
    Aug 21 '19 at 22:26
  • The question asks for magnets, this answer relates to .torrent files. Nov 21 '20 at 9:42
  • Like the comment above yours, it helps resolve the issue, somehow shrugs
    – Vijay
    Nov 22 '20 at 20:23
0

Late answer, but this may help people specifically trying to use Deluge in Windows. Which I think they stopped updating in 2017.

Windows wants you to choose a magnet handler through a specific options screen, "Choose a default app for each protocol". But that screen doesn't have 'magnet'.

The problem is that windows is missing some registry stuff for magnet links. In most torrent programs, you can check some option to make your program the preferred magnet handler. Checking that option adds the needed registry info. But Deluge doesn't have any such option.

The fix

The earlier answer with a registry fix is mostly correct. Where you might get frustrated is if you try to just add that key manually like this:

HKEY_CLASSES_ROOT\Magnet\shell\open\command

then, change default value to...

"C:\Program Files (x86)\Deluge\deluge.exe" "%1"

This will result in nothing happening when you click magnet links. The reason it doesn't work, is because there's a few other details that need to go into the magnet subkey in the registry. There's two ways to add those details. The easy way is to just install a modern torrent client like qbittorrent. The necessary registry stuffs will be created. then you can change the registry path so that it points to Deluge insead of QBittorent.

The other way is to manually add the missing items. Out of laziness I'll just screenshot these:

magnet registry entries

you can see there's also a "Default icon" key, I'm not sure if this is needed. Mine has one value, the default, which is set to: "C:\Program Files\qBittorrent\qbittorrent.exe",1

Hope this helps if anyone can't get magnet links to behave.

-1

HOW TO FIX Chrome version 63 or higher keeps popping up mod window of "always open these types of links in the associated app" even after clicking - it doesn't remember - bugs chrome -.. 1) Go to search box on your taskbar and type "run" 2) In Run, type %appdata% and press OK. 3) Press AppData on the top, and go to Navigate to C:\Users\YOUR_USER_NAME\AppData\Local\Google\Chrome\User Data\Default\Preferences 4) Open it with Notepad. 5) Press Ctrl+ F and find "protocol_handler":{"excluded_schemes":{}}, and click Find Next. 6) Replace that part with "protocol_handler":{"excluded_schemes":{"magnet":false}},?

for torrent magnet links

or for roblox users instead Replace that part with

"protocol_handler":{"excluded_schemes":{"ROBLOX":false}}"?

1
  • For me this answer was (part of) the solution. Chrome did not handle the new torrent client and kept using the old one. I uninstalled the old one, added the excluded_schemes from this answer and re-checked magnet association in the new torrent client. After a reboot everything is working perfectly!
    – mrexodia
    May 12 '19 at 14:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.