1

I have a dual boot with Windows 8 and Fedora 20. Since 2 days ago, it worked well, but actually I rarely use W8. I booted briefly on it and it decided to install some updates, which made Windows booting directly, and I no longer have access to Grub.

I tried many things to recover it, I reinstalled grub2 using a chroot, I tried to wipe completely the EFI partition and restore it (it didn't change anything of course), without success. Windows still boots directly. I tried many things, even changing the "{bootmgr}" variable using bcdedit on Windows to refer to "\EFI\fedora\grubx64.efi" (I tried many different paths, no success).

The last thing I wanted to do is reinstall completely Fedora (and keeping my /home, since it is on a different partition), but the installer won't let me :

You have not created a bootloader stage1 target device.

You have not created a bootable partition.

It seems to be a known bug, yet it worked when I installed my system. My disk uses GPT as partition format.

My laptop is a Sony Vaio Pro, which is known to have bootloader problems (I can't find the link that described it, sorry), yet it worked out of the box with Fedora 20 (that wasn't the case with 19).

I hope to finally find a solutio, I'd like to avoid complete wipe of the disk (even if most of my work is saved/versionized, I don't want to reinstall everything).

Thank you in advance!

  • Many many years ago, this aggressive offense against the boot sector is what caused me to stop using Windows completely. – L0j1k Nov 26 '14 at 7:41
  • What happens if you use the UEFI shell and try to boot grub? Also did you verify the boot device order is still ok? – Mario Nov 26 '14 at 8:02
  • 1
    @L0j1k I agree, I actually kept it because I needed it once, but no longer. Mario: UEFI Shell wouldn't launch, and I finally found a solution thanks to EasyUEFI to change the bootorder. – pcouderc Nov 26 '14 at 11:22
  • Best of luck to you cutting the cord completely! :) – L0j1k Nov 28 '14 at 8:20
1

Ok so, I finally found a solution: it seems Windows completely messed up the bootorder. I used EasyUEFI (I couldn't launch UEFI Shell), and first tried to change the boot order. After reboot, the order had been reverted (by Windows ? I suppose). I finally disabled the Windows boot entry, and it worked.

I really don't know what happened, if this is Windows that changes the boot order or the bios of the VP, but it amazes me. Good bye Windows, I won't miss you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.