1

I've been using a software which gives the output in .csv format automatically. In my .csv output file "." is used as a decimal separator. In my colleague's computer, the same software outputs the .csv file with "," as a decimal separator. I've tried too many things like excel template settings, changing regional settings, etc.. but did not succeed yet. I share the configurations for both computers below.

My Laptop ;

  • OS : Windows 7 x64, English
  • Region & Language Settings : Italian
  • Excel 2010 : English

Colleague's Laptop ;

  • OS : Windows 7 x64, Italian
  • Region & Language Settings : Italian
  • Excel 2010 : Italian

Can anyone tell me how can I get the output .csv file same as my colleague's? The main objective is to get "," as a decimal separator instead of "."

PS : I can't edit .csv output file manually because this output file is used by another system for a production of high tech. components in industry...

1
  • 2
    Change "English Region & Language Settings" to use "," instead of "." as a decimal separator. – DavidPostill Nov 26 '14 at 8:37
0

TL;DR Link the CSV in Microsoft Access. Use the text export feature and specify your decimal separate as comma (,) and field delimiter to tab.

For this example to work, you need Microsoft Access. I will assume you have a CSV file and do not require the use of Excel.

  • In Microsoft Access 2013, create blank database

enter image description here

  • Link existing CSV file to the new database. You can also "import" the CSV if the file is in use by another program, but you will have to re-import every time.
  • Make sure that you specify the column that needs to have special decimal handling to be imported is given a type of double

enter image description here

enter image description here

enter image description here

  • Once linked, you have to export the CSV as a text file.
  • Take care that this "Text File" selection is different from the previous "Text File".

enter image description here

  • Now, click Advanced and change the Decimal Separator to comma (,)
  • Your field delimiter also needs to change to something else such as tab.

enter image description here

  • Once you save the CSV this way, you should get a file where the decimal separator (,) and field delimiter is tab.

enter image description here

There are ways to automate this entire process by saving the export template as a "specification" and by creating an Access Macro you can reference from the command line Access

-1

As you say that you can't edit the output file because it is used by another system there is a different solution:

  1. In Excel click "File" in the menu bar
  2. Click "Options" in the list of possibilities
  3. Click the "Advanced" tab
  4. In the section for "Editing" you can set the option for "Use system separators"
  5. Set your preferred setting for the decimal and/or thousands separator
  6. Click "Ok" to save your settings
1
  • thanks but I already have this setting in excel.I tried also by setting "," from this area but no change in the result output...There is something on the background that makes the software use "." instead of ","... – NT. Nov 26 '14 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.