0

I have an very old application, from repository - it's soundmodem (for amateur AX.25 radio packets).

I'm using Linux Mint 17 with default sound driver, it's PulseAudio. Options in application configuration:

  • soundcard: /dev/dsp, /dev/dsp1, ...
  • alsa: hw:0,0, plughw:0,0, hw:1,0, ...

And checkbox for Half duplex and Capture channel (mono / right / left).

I can't make this application works together with Chrome or other application that plays sound to mixer. I tried to run this with padsp (on stduser or root) and set device to /dev/dsp (what works in other apps), but i got error:

sm[10925]: audio: starting "/dev/dsp"
sm[10925]: audio: forcing half duplex mode
sm[10925]: audio: Error, cannot set nonblocking mode

Any ideas how to run this?

EDIT: ALSA options:

ALSA options

  • Did you try ALSA device default? – CL. Nov 26 '14 at 13:59
  • @CL. look at updated post – aso Nov 26 '14 at 14:14
0

The correct ALSA device name to run on PulseAudio would be default.

Apparently, soundmodem does not allow to use this device name. You have to disable PulseAudio temporarily and let that program use the ALSA device directly.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.