5

I'm trying to connect to our FTP on an IIS server and I'm having issues viewing files/folders. My manager is able to connect with no issues and it's been a long time since he set it up. We added a Windows account for me and I'm able to connect, but unable to access folders. We set the permissions on the server so I have full control, but it still doesn't seem to want to allow me to access it. Any idea what we might be missing? We've tried restarting the FTP service, but that didn't seem to work either.

FileZilla logs:

Status: Retrieving directory listing...
Command:    CWD /folder_name
Response:   550 Cannot create a file when that file already exists. 
Error:  Failed to retrieve directory listing

CMD:

ftp> cd folder_name
550 Cannot create a file when that file already exists.
  • "We set the permissions on the server so I have full control" Can you expand on what you did exactly? Did you ensure that account has permission to access the folders/files themselves (at the Windows file system level)? Can you create your own new folders successfully? Are you on the LAN with the FTP server? Is the server setup to be Passive or Active? – Ƭᴇcʜιᴇ007 Nov 26 '14 at 17:14
  • Yes, we set the permissions on the folders themselves. I have full access when I RDP into the server. I am able to create folders in the root FTP directory. I just can't delve any deeper with the folder that my manager has been working in. The permissions of that folder are inherited from the root dir. We're connecting remotely over WAN. We're using Active. Passive won't connect for either of us. – JeremyT Nov 26 '14 at 17:19
  • So if you do create a folder in the root (via FTP), can you CWD into it? If so, then there's something whacky about that folder you're trying to access. Are the folder(s) you're having trouble with virtual directories or regular folder directly in the FTP site's file structure? – Ƭᴇcʜιᴇ007 Nov 26 '14 at 17:26
  • Yeah, I'm able to access the folder I created with no issues. It's a regular folder on the drive of the server. Perhaps I'll try tinkering with just that problem folder's permissions a bit more... – JeremyT Nov 26 '14 at 17:29
  • Definitely sounds like a folder permissions issue to me, but odd you can get into it when logged in via RDP (same user account I'm assuming, right?). Perhaps the easiest "fix" is for you to make a new folder, then get your boss to copy the work to it and delete his original folder, and then just work from the folder you can both access. :) – Ƭᴇcʜιᴇ007 Nov 26 '14 at 17:33
0

I figured it out last week. In the C:\Windows\System32\inetsrv\config\applicationHost.config file, there was an extra set of permissions for the problem sub-directory that was causing the issues. Once I removed that, it worked as expected...

0

I had a similar problem, receiving the following message when logged in to an IIS 8.5 FTP server:

ftp> cd folder_name 550 Cannot create a file when that file already exists.

I believe the problem started after changing the physical path of the FTP site when FTP authorization settings had already been applied. The fix was to delete the FTP site from within IIS, point it to the correct physical path, then re-apply authorization settings via the "FTP Authorization Rules" icon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.