A few hours ago Chrome closed on my MacBook Air with OS X Yosemite 10.10.2 and there's no way to recover it. Everytime I try to launch it quits with the message "Google Chrome has quit unexpectedly", giving me the option to send a report to Apple, Ignore, or restart Chrome. And the same happens afterwards.

I've tried to launch a safe session of Chrome with the "--safe-plugins" options without success, here is what happens when I do this from the terminal:

Mac-705681ad12c1-2:MacOS javipas$ ./Google\ Chrome --safe-plugins
2014-11-26 18:02:09.266 Google Chrome[921:21325] -[NSTouch _initWithPreviousTouch:newPhase:position:isResting:]: unrecognized selector sent to instance 0x7fb71afabcc0
[921:1299:1126/180209:FATAL:chrome_browser_application_mac.mm(148)] Someone is trying to raise an exception!  NSInvalidArgumentException reason -[NSTouch _initWithPreviousTouch:newPhase:position:isResting:]: unrecognized selector sent to instance 0x7fb71afabcc0
Trace/BPT trap: 5
Mac-705681ad12c1-2:MacOS javipas$

I've also tried to delete Chrome from the Apps folder and install it again, but no success either. Any ideas, please?

  • There are some more things to try. Have a look at the answers to this question – Nifle Nov 26 '14 at 17:40
  • Got today the same problem – Peter Shipilo Nov 26 '14 at 22:06
  • Please notify it here if you will find a solution. Last time Google Chrome makes me cry. – Peter Shipilo Nov 26 '14 at 22:13
  • 1
    Found this relevant bug report: code.google.com/p/chromium/issues/detail?id=435779 I too am experiencing this issue. Complete uninstall and reinstall of Chrome did not resolve the issue. Even tried installing Canary and it has the same crash. It appears to affect Chrome 39 so I'm going to see what it takes to downgrade. EDIT: More on that it appears to only affect OS X Yosemite Seed users. – Peter Nov 26 '14 at 22:48
  • Same issue here starting today. – user196235 Nov 27 '14 at 8:40

Just a guess:

This could be an issue with your user profile in Chrome. I know I've had this problem before on a Windows PC. This would make sense since uninstalling and reinstalling the application in Mac would not remove these user files.

It's possible they might have been corrupted or damaged.

Navigate to:

~/Library/Application Support/Google/Chrome/

Rename the folder Default to something like Default-Backup and relaunch Chrome. It should generate a new default profile and hopefully your problem will be fixed.

Doing this, however, will cause you to lose your data. Turn on Chrome sync before you start this process if you are worried about losing anything.

I suppose that if the fix works, you could 'cherry pick' files and folders from the backup directory until it starts having the problem again to narrow down the file that might be the root cause of the crashing.


The Problem:

Judging by the amount of attention chromium issues has gotten over the past few days, it looks like the problem you are describing is caused by an issue with the Mac touch pad driver.

But this is a weird bug because it's clearly not affecting everyone, even people with the most updated version of Mac OS X (10.10.2). But according to this, the problem stems from Apple depreciating the isResting selector and then completely removing it in the most recent update.

Again, the error people are reporting looks like this:

[NSTouch _initWithPreviousTouch:newPhase:position:isResting:]: unrecognized selector sent to instance

The Solution:

It looks like some people are simply plugging in external mice and if they don't touch the trackpad, it's fine. If this sounds like a good solution, make sure you also enable “Ignore trackpad when mouse.” in Accessibility settings.

You could try downgrading Chrome if the former option sounds like a hassle. Not sure if this would work, but it might be a good try.

I imagine a patch will be pushed out to canary builds over the next couple of days or Apple will send out a new driver update (but probably not since they were working to remove isResting). I would stay on the lookout for that.

  • Hi, I have the same problem. Tried ti fix it in this way. Unfortunately it din't help me. – Peter Shipilo Nov 26 '14 at 22:12
  • Great suggestion, but this doesn't seem to be working for this issue. – user196235 Nov 27 '14 at 8:41
  • I edited the post to summarize the tracked issue. It seems like many people are having the same problem and I would expect a bug fix in the near future. – James Taylor Nov 27 '14 at 18:10
  • yaa basically deleting all the old files. fixes everything and starting all over again. – abhimanyuaryan Sep 16 '15 at 22:19

Option 2 of Pippyn's answer works so giving the full temporary fix (I can't just upvote the answer):

[1] Put the following in a file "patch.m":

#import <AppKit/AppKit.h>

__attribute((constructor)) void Patch_10_10_2_entry()
    NSLog(@"10.10.2 patch loaded");

@interface NSTouch ()
- (id)_initWithPreviousTouch:(NSTouch *)touch newPhase:(NSTouchPhase)phase position:(CGPoint)position isResting:(BOOL)isResting force:(double)force;

@implementation NSTouch (Patch_10_10_2)
- (id)_initWithPreviousTouch:(NSTouch *)touch newPhase:(NSTouchPhase)phase position:(CGPoint)position isResting:(BOOL)isResting
    return [self _initWithPreviousTouch:touch newPhase:phase position:position isResting:isResting force:0];

Compile it:

clang -dynamiclib -framework AppKit patch.m -o patch.dylib

Use it:

env DYLD_INSERT_LIBRARIES=/path/to/patch.dylib "/path/to/Google Chrome.app/Contents/MacOS/Google Chrome"

Part 2 Automator

In Automator select Run Shell Script, paste the command above and save as app to desktop

  • I would highly recommend not patching your own system. Apple probably deprecated and removed the code for good reason. Who knows what kind of issues this might create. It's passable, but I wouldn't advise it. – James Taylor Nov 28 '14 at 2:54
  • This is just for the automator script. It doesn't actually patch the system itself. The issue seems to have gone away now with the latest 10.10.2 – David Glance Dec 8 '14 at 12:16

It's a problem with the new trackpad driver in OSX 10.10.2.

OPTION 1: You could use a external mouse en disable the use of the trackpad while a USB mouse is connected. (Accessibility>Mouse & Trackpad>Ignore built-in trackpad when mouse or wireless trackpad is present)

OPTION 2: (found on Reddit) This fix is not the best solution, but it works. When you follow the instructions you'll have to run the last terminal command every time you want to run Chrome. But you can also make a chrome launcher with the automator app and the terminal command.


I got this problem solved by basically renaming some other file called ~/Library/Application Support/Google/Chrome/Local State. I renamed it to Local State-backup.

Now I started chrome again, it starts and creates fresh Local State file. You don't need to touch ~/Library/Application Support/Google/Chrome/Default folder at all.


The problem is fixed as of December 20th, 2014 on OS X Yosemite. I'm not sure when Apple released the newer version of OS X, but currently I can open Google Chrome using the normal method and move my mouse without it crashing.

The prior patch listed above will cause the program to crash if you move your mouse when starting Chrome.


If you are using Chorome Canary follow these steps. It worked for me. No data loss. Even I got all my tabs back.

1) Open terminal and issue these commands

cd ~/Library/Application\ Support/Google/Chrome\ Canary/
mv Local\ State Local\ State_bkp

2) Launch Chorome Canary

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.