I'm trying to install and run Ubuntu Server 14.04.1 LTS on a VirtualBox for testing purposes. However, I can't even pass the installation process without errors, and it will fail to install the GRUB boot loader every time, no matter how I choose to configure the system.

I ran installation leaving everything with it's default value:

Partitioning Method: Guided - use entire disk and set up LVM
Disk: SCSI3 (0,0,0) (sda) - 2.1 GB ATA VBOX HARDDISK
Amount of volume group to use for guided partitioning: 1.9 GB

The partition tables of the following devices are changed:
   LVM VG dev-vg, LV root
   LVM VG dev-vg, LV swap_1
   SCSI3 (0,0,0) (sda)

The following partitions are going to be formatted:
   LVM VG dev-vg, LV root as ext4
   LVM VG dev-vg, LV swap_1 as swap
   partition #1 of SCSI3 (0,0,0) (sda) as ext2

Write the changes to disk (y/N): y

Automatic updates:
   [*] No automatic updates

Additional packages to install:
   [*] LAMP server
   [*] PostgreSQL server

Everything runs smooth, till:

[!!] Install the GRUB boot loader on a hard disk
   Installation step failed
   An installation step failed. You can try to run the failing item again
   from the menu, or skip it and choose something else. The failing step is:
   Install the GRUB boot loader on a hard disk

After restarting, I'm left with a black screen without any possibilities to boot it manually.

I can't really make out the source of the error, so I'd be glad for any thoughts on this.

My VirtualBox:

Name:               sdm
Operating System:   Ubuntu (64 bit)

Base Memory:    512 MB
Boot Order:     Floppy, CD/DVD, Hard Disk
Acceleration:   VT-x/AMD-V, Nested Paging

Video Memory:           12 MB
Remote Desktop Server:  Disabled
Video Capture:          Disabled

Controller: IDE
  IDE Secondary Master: [CD/DVD] Empty
Controller: SATA
  SATA Port 0:          sdm.vmdk (Normal, 2.00 GB)

Host Driver:    Core Audio
Controller:     ICH AC97

Adapter 1:  Intel PRO/1000 MT Desktop (NAT)

Device Filter:  0 (0 active)

[Shared Folder]


I finally got rid of the error. And to be honest, it's stupid.

The problem actually was, that the /boot partition wasn't created, even though it was shown in the UI. It's still possible to get everything running with the guided partitioning, but when you're asked to Write the changes to the disk?, you need to go <Back> to see a detailed list of all partitions. When clicking <Next>, the installation will finally recognise and partition everything correctly and as expected.

| improve this answer | |
  • That worked for me too. Is that a bug with virtualbox? – Juzer Ali Dec 22 '15 at 10:14

I had similar problems with virtualbox. The other answer did not help. What I did was also simple. I created an vmdk harddisk instead of vmi (set HD to size I wanted). That's it, hope this helped!

FYI, I installed kwickserver install cd for mail and instant messaging

| improve this answer | |
  • Same, switching to VMDK over VMI allowed grub to install. When prompted, install grub on /sda. Win 10 host, Debian 9 guest, Virtualbox 6 – Tom Apr 24 '19 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.