2

I will try to narrow down my questions because I realize this topic is super broad.

I'm trying to create a Linux bootable USB disk with persistence for the most recent version of Lubuntu (14.10). I've done this many times in the past. To my recollection, it's been finicky at best, but I've always managed to get it to work.

Creating a bootable disk seems simple enough. I used Universal USB Installer, Linux Live USB Creator, and UNetBootin on Windows and used UNetBootin and the standard Ubuntu Disk Creator on Linux. Despite using a multitude of tools, when I boot to the USB, I get the message:

Missing Operating System.

I can confirm this on multiple computers that I know have a BIOS properly configured to read from the USB. Like I said, I've done this before, so I mildly know what I'm doing.

So this experience creates a lot of questions for me:

What am I doing wrong?

I'm trying to write to a 4GB SanDisk Cruzer which, albeit is ~ 1 year old, should work fine. The disk has been formatted by the respective programs and I also partitioned the USB using a disk utility.

What should I try next?

Are there ways to check the integrity of a bootable USB? Can it be repaired so I don't have to go through the process over again?

Are there boot flags that should be checked? Can I get more verbose output as to why the USB won't boot?

Any suggestions on this topic would be greatly appreciated.

2

Maybe it's the USB flash drive. It's been formatted so many times that it may have broken bits of bootloaders still remaining on the drive that the BIOS mistakenly recognizes as bootloaders for an operating system that no longer exists on that drive. Reformat the USB flash drive with GParted, including resetting the boot flag, and then try again to make a bootable Lubuntu 14.10 live USB using the Ubuntu Startup Disk Creator application.

I had the same problem booting an Ubuntu live USB using an 8GB SanDisk Cruzer flash drive, and this was how I solved the problem. I'm not sure if my theory about the old bits of bootloaders remaining on the USB drive is correct, but using GParted to reformat the drive and after that Ubuntu Startup Disk Creator was what worked for me.

| improve this answer | |
  • 2
    Yep, that's basically what fixed it. I had to wipe the disk using sudo dd if=/dev/zero of=/dev/sdX bs=256. After that, I used gparted to create a new partition table on the device and a new fat32 partition. Then I used the Ubuntu startup disk creator and it worked. – James Taylor Nov 27 '14 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.