This problem shows up using Firefox 33.1.1 on Windows XP (Service Pack 3).

NBA Stats allows you to review past games by watching play-by-play video segments. I use this website to cross-check my logs for my Preventions project. For example, say you want to review a play that happened between the Raptors and Hawks (we'll use this as my example):

  1. On the home page, click "Scores" on the grey bar.
  2. Use the "Calendar" to select November 26 to bring up the games from that date.
  3. With the page loaded, look for Toronto Raptors (TOR) vs. Atlanta Hawks (ATL). Click on the "Play-By-Play" link of that game.
  4. On the play-by-play page, click any event to bring up a "Video" pop-up. Click on "Video."

Normally, a video would appear on the left pane with a thumbnail of the active video on the right. The problem I’m having is that when I do this through Firefox, all I get is a black screen. I can hear the audio, I just can't see the video. This is how it looks on my end:

enter image description here

I know for a fact that AdBlocker and NoScript — both used to improve web browsing — are not at fault, since I’ve removed both of them to be extra sure. The image I included was taken with both add-ons uninstalled prior to this post.

The only way I can view any video from NBA Stats is to use a different web browser. Internet Explorer is discontinued due to security issues, and Apple Safari for Windows is no longer available. I can no longer use Google Chrome because it actually crashed my computer every time it accessed my audio driver, and Chrome by itself is another story entirely.

Why can’t I view videos on NBA Stats through Firefox? If I went to another website like YouTube, I can view them just fine. It’s only that website where I’m having problems.

  • Odd, does the same thing on Firefox running on Windows 7. Works fine in Chrome. – Fiasco Labs Nov 28 '14 at 3:14

Are these Flash videos? Could be possible if they are streaming into Firefox on Windows XP. If so it could be an issue with the security settings connected to streaming third-party content to your machine. More details here on the official Macromedia site; these specifics seem to be in play:

When you visit a website, the address shown in the browser address bar is usually where most of the website is located. For example, if you visit a fictional website www.[hotel].com, most of the website is located at www.[hotel].com. Sometimes, websites combine content from different sources. For example, www.[hotel].com might display a reservations form in Flash that actually comes from [reservations.hotel].com. The content from the latter website is called third-party content.

Third-party content might try to store information on your computer. In the hotel reservations example, you might be willing to let [reservations.hotel].com store information on your computer, such as data about which hotels you prefer, so that you can make a hotel reservation. However, you might not be willing to let third-party content store information on your computer in other situations. For example, a car-rental company, www.[my-car-rental].com, might have a banner ad on www.[hotel].com, to track your website usage or to record your preferences.

To prohibit all third parties from storing information on your computer, deselect Allow Third-Party Content To Store Data On Your Computer. This option is available only with Flash Player 8 and later. Adobe recommends that you upgrade to the most recent version of Flash Player available.

Which all basically means that if you are having issues, possibly enabling third-peaty data to be stored on your machine locally would solve the issue. If you go to the Macromedia page I have linked above—and here again as well—you will see a control panel like this:

enter image description here

Just check off that box next to, “Allow third-party Flash content to store data on your computer.” And see what happens.

  • No change. It actually took away the thumbnail button. Now it's just a black screen with a tiny little grey box. – Wammy Nov 28 '14 at 4:20
  • @Wammy Sorry this didn’t work. Will see if I can dig something else up. – JakeGould Nov 28 '14 at 4:29
  • @Wammy Another idea: Does your video card driver have video playback acceleration? That is when the driver basically grabs video content and “speeds up” rendering by pushing it through it’s 3D engine. In many cases if you disable that feature on the driver video will play again. – JakeGould Nov 28 '14 at 5:01
  • The video card I have is an NVIDIA GeForce 8400GS, a 2 GB Video RAM card, and it works perfect. I do not want to mess with it for fear of hurting my computer, and I've already done it once when I tried to update my BIOS (which I shouldn't). – Wammy Nov 28 '14 at 5:20
  • @Wammy It’s not a BIOS or hardware change I am talking about. It is usually a software driver setting that is easily enabled as well as disabled for testing like this. No big deal. – JakeGould Nov 28 '14 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.