1

I love the feature of Windows Media Player where you can right click a music folder and select Play With Windows Media Player because I organize all my music in individual folders (and subfolders for that matter).

I know that it is possible to open (and play) a whole folder through the open menu of VLC Media Player.

Is it also possible to have a context menu on a folder (in Windows) which works the same way? How can I enable this (is it somewhere in the advanced VLC settings)?

0

This feature is available in the latest VLC player. Please the image below where right clicking the vlc media player asks to add it in player list. vlc version for the image 2.1.5

enter image description here

2

Adding a subtlety to what has already been said. In windows if the file association for songs is not VLC the context menu in windows explorer will not appear.

3
  • This seems to be a comment on an existing answer rather than a complete answer. – Blackwood Dec 3 '17 at 2:08
  • I am not "reputable" enough to comment on someone's answer :) Please add it as a comment to the original answer and I will delete this. Feel free to recommend a better way to address the issue at hand. – Jehandad Dec 3 '17 at 4:27
  • This solved my problem. – E_Blue Jun 20 '18 at 3:11
1

...and if you're running the latest version, and don't have the menu item in your context menu?

Find your installer (or if you can't find it, download the latest one) and run it. You will be given a chance to reinstall/repair the settings (picture).

Take the defaults, or at least ensure that Context Menus is selected (picture) and you should be good to go.

I've noticed, however, that if you are manually selecting files, selecting more than 15 files will cause the "Add to VLC media player's Playlist" option does not appear. To get around this, select groups of no more than 15 files, or select the folder from the parent folder's file listing instead.

1

The way I did this was:

Computer\HKEY_CLASSES_ROOT\Directory\shell

  1. Add new key named PlayWithVLC, edit its default string to: Play With VLC
  2. Under PlayWithVLC, add a new String Value named Icon, edit its value to: "C:\Program Files\Videolan\VLC\vlc.exe",0
  3. Under PlayWithVLC key, add a key named command, edit its default string value to: "C:\Program Files\Videolan\VLC\vlc.exe" "%1"

At least its working for me.

Some people say that you should clone these settings in another registry location, but I can't find that reference now.

-Marine

1
  • This worked for me. But be advised you'll have to make sure you get the correct path for vlc.exe. My copy was in the "Program Files (x86)" path. – Joe M May 17 at 18:20
-1

Just have your VLC Media Player updated to the latest version and make sure that all the media file types in that folder open with VLC by default. To open a media file with VLC by default, right click on the media file, click on Properties, click on change and select VLC. Then click Apply and click Ok. Now, when you right click on the folder, you will have the option "Play with VLC Media Player".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.