9

While working on a Excel for Mac, I suddenly cannot enter any data in ANY cell. Also the same thing with all my spreadsheets, unrelated to the one I was working on. I can type numbers and letters on email and blank pages, but not on the spreadsheet. Help

  • What happens when you enter a date in a cell? How it is displayed? – vembutech Nov 28 '14 at 21:00
  • "I can type numbers and letters on email and blank pages, but not on the spreadsheet." Is your problem limited to dates, or can you not make any spreadsheet entries regardless of data type? – fixer1234 Nov 28 '14 at 21:29
  • I can not enter anything. Another person said I should try turning off the computer and restarting to see if it will help. I will try that next. – Sandra Nov 28 '14 at 21:40
  • 2
    @Sandra For future reference, try restarting your computer before putting your time into asking others for assistance. That solves so many problems it's really a waste of your time (and others) to seek help before trying this solution. – Twisty Impersonator Nov 28 '14 at 23:00
  • Still happening in 2018. – Jir Nov 5 '18 at 14:57
6

It's not that you needed to close another workbook; all you need to do is to click on a different workbook, and then you can then come back and edit the cell in your original document. Just taking the focus away from the first document frees it up.

We can reproduce this at will, but we don't know why or what makes it happen to get stuck in the first place. Others on the web have this issue as well. So far, only 1 of our users have this issue and we just put everyone onto 2013.

0

The issue could be because of the following option might enabled in your excel. Please un-check "Transition formula evaluation" and "Transition formula entry" options under "File > Options > Advanced. These two options available at the bottom of 'Advanced' option.

enter image description here

Hope this helps

0

This happened to me - super frustrating. It turned out I needed to close a second workbook that I had open. I don't know why, but it worked.

0

It seems that there are several things that could be causing this issue.

NC Admin's solution worked for me, but I was able to fix it myself by making my formula bar viewable. (View > Formula Bar). After unhiding the Formula Bar and editing a cell's text, I was able to hide it again and still be able to edit a cell's text.

0

I have had this problem. I would be unable to enter data in a cell and would have to switch to another worksheet and back. This could happen every second cell update. I had another (timesheet) spreadsheet open, with hundreds of worksheets. When I closed that spreadsheet, the problem went away.

  • This gives the same solution as an existing answer. – Chenmunka Dec 19 '16 at 12:22

protected by Community Aug 18 '17 at 8:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.