0

Technically it is "almost" a bootloop, since I can boot ubuntu on the hard drive, and I could boot from the DVD (breaking ubuntu grub on the hard drive or trying to chainload to the dvd).

Still, it is a ugly situation from which I'd prefer to escape.

  1. Bios don't see usb storage devices anymore
  2. Bios setup screen and Bios choose-a-boot-device (f2, f10) don't work anymore
  3. Bios recovery key (f4) fires but samsung recovery stalls at boot
  4. Bios is in CSM mode
  5. Fiddling around with efibootmgr from linux would be nice to try to fix the setup screen in 2 (prolly it's a missing nvram efi entry, "Setup"), but since the laptop is in CSM, no efi strings available. great.

  6. Since the laptop is in CSM, Windows 8 won't boot, and I cannot reach the "go in efi firmware setup screen" during restart.

So, basically, I'd kind of like to send the firmware in uefi mode at next boot, running a command from linux in csm mode.

Any idea?

Using Samsung support would be pricey and very unconfortable (in the meantime they are practically retiring from the european laptop market),

probably I'd rather dump the damn thing and buy another with a more sensible efi implementation (*) - and send Samsung to where they belong for good.

(*) I'll save you from hearing how I got that deep into trouble, but let's say it is because I was trying to fix a problem that I don't know if it war originated by the Phoenix bios itself, but surely I'm bitter about Phoenix not giving us an actual way to reset the firmware status to the default, and Samsung for not giving us the firmware images to reflash.

2

I own a Samsung series 9 laptop (NP900X4C) with a Phoenix BIOS, Windows 8.1, and I had to boot to a USB device with Debian.

First, I make my USB with a tool supporting UEFI (I use Rufus).

Second, in BIOS (access by F2) I set Fast BIOS to Disable (enabling USB Legacy).

Third, I reboot via Right Charms menu, Change PC Settings, Update and recovery, Recovery, Advanced Restart, and after restart, Use Device, USB HDD. And my laptop boots from my USB.

I try F10 to choose boot device, and changing boot order in BIOS (access by F2), and it works too. As my boot on USB are exceptional, I prefer Windows method.

When I don't use USB, I reset Fast BIOS to Enable. It's empiric, but it works. Hope this helps, even if I'm not sure I understand all of your post (English is not my native language).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.