0

How do you completely remove and/or disable the VLC plugin for Firefox?

Standalone VLC is great, but for some reason, it never works in Firefox. It takes forever to load and then it doesn't play anything. Even worse, it overrides the Firefox application setting, so it essentially prevents me from manually downloading WAV and MP3 files. How do I disable this, or at least get it to respect my application setting so Firefox will "Ask me" instead of automatically loading VLC? And yes, I already tried the "Applications" tab under File->Edit.

1

You can disable the the VLC(or any) plugin from the Addons Manager in Firefox. You need to restart firefox to effect the changes.

Click here for image

| improve this answer | |
  • Thanks. Although my version of Firefox is a little different (I'm on Linux?) and didn't require restarting. – Cerin Nov 30 '14 at 5:17
0

In my Firefox, for some reason the VLC plugin and the Shockwave Flash plugin seemed to be linked.

So when I set the VLC plugin to 'never activate' as the option is now called it also set the Shockwave Flash plugin to 'never activate' as well. And when I reset the Shockwave Flash plugin back to 'always activate' then the VLC plugin got set back to 'always activate' as well.

The way I disabled VLC was this:

  1. type 'about:plugins' in the address bar. The page that comes up will list the file location for each of your plugins
  2. find the location of the VLC plugin - in my case it was: C:\Program Files (x86)\VideoLAN\VLC\npvlc.dll
  3. rename that file

That will remove the VLC plugin. You can always change the file name back to the original if you want VLC back again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.