3

I’ve noticed in OS X Yosemite (10.10.1) that my Brother MFC-7820N no longer seems to have OS-level support for scanning.

If I look in “Image Capture”, the scanner is not listed under shared devices and if I look in the “Print Queue” window, the “Scanner Panel” window is unavailable; disabled in the Windows menu. Apple and Brother both still officially support this model with Yosemite.

I’ve tried manually installing the Brother 4.5.0 printer and scanner drivers from the Brother web site, just in case the problem had something to do with the automatic installation from Apple. The Brother drivers include the “Control Center” utility and I can scan just fine using that, so the scanner does seem to be working.

I’m at something of a loss on how to even try to diagnose this issue, since there aren't any error messages I'm receiving.

3
  • How are you connected to the Brother MFC-7820N? The support page shows parallel, USB and Ethernet options for connectivity. – Giacomo1968 Nov 30 '14 at 5:36
  • I don’t have a way to test this, but I have a funny feeling this is Ethernet connected more than being driver connected. But someone posted an answer that sounds like it’s worth a shot so feel free to check that out before doing anything else. – Giacomo1968 Nov 30 '14 at 7:33
  • I have the same problem on Os x El Capitan. I can print to the printer but no scanning. An older snow leopard mac scans from the device just fine... – Digikata Mar 23 '16 at 6:47
0

Try connecting to the device using a USB cable.

I have the same issue with a Brother DCP-9010CN. I notice that Brother's OS X Yosemite Support Statement mentions that:

"Scan to Network" function is not supported in OS X v10.10.x.

Perhaps this means scanning over the network is not supported. With a USB cable, I was able to scan.

0

The scanner uses a separate scanner driver (Country specific web sites, try the direct link Brother_ScannerDrivers_1_0_0.dmg.

Found it by search for MFC-7820N and filtering for 10.10.

Looking in the install package contained within there's a Brother Scanner.app. Shows a date of October 10, 2014.

The MFC-7820N is listed in the com.brother.DeviceDB.plist for the app.

It also contains a TWAIN driver.

If that doesn't work by itself see TWAIN Scanners in OS X Maverick (and Yosemite).

I don't have a Brother scanner to try it. Apple supports a lot of printer/scanner vendors directly (Cannon, Epson, FujiXerox, Gestetner, HP, Infoprint, Infotec, Lanier, Lexmark, NRG, Ricoh, Samsung and Savin), although I'm sure with vendor help. Notice Brother is missing from the list.

1
  • Thanks for your help @DavidKoontz! I tried the recommendation from that site, but sadly, it didn't seem to make a difference. Apple does support Brother (at least in theory), according to their HCL: support.apple.com/en-us/HT201465. – Timothy R. Butler Nov 30 '14 at 7:38
0

I'm working at a small company and when I went to upgrade computers from 10.9 to 10.10, I had the same issue. They could no longer scan through Image Capture.

When I called the Brother, they told me that they no longer supported that option (scanning to network). However, they did support scanning through the Brother Control Center application.

0

Apple has my device on their supported list at https://support.apple.com/en-us/HT201465 but it didn't start out showing my shared list on 10.13.2 High Sierra.

Eventually I got it working; here's what I did but I don't know which step did it:

  • Used the automatic Mac printer install by selecting the bonjour printer
  • Downloaded and installed the Printer driver from Brother
  • Downloaded and installed the Scanner driver from Brother
  • Used the add new printer button again but manually selected the newly installed BR-Script (PS emulation) driver
  • (At this point the shared list was still empty)
  • Restarted the the computer

Now it shows in my shared list and seems to function fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.