2

I ran Commands / Synchronize dirs in TotalCommander, but after synchronization it still refuses to synchronize few files. Why?

The screenshot is posted below. The red files are those problematic files - they actually are different, already exist in the target directory, new version is available, but when I click on "Synchronize", TotalCommander won't do anything.

enter image description here

I use version 7.55 32 bit

1

As far as I know, if you have files with same name/location but different content you have to explicitly select the action you want to do with those files before synchronization.

For example, select all files and hit CTRL+L, which will copy all the conflicting files from left to right panel after you hit Synchronize (which seems to be what you need, given that the files in the left panel are newer).

You can also choose other actions (just right click the file to see the list of options).

  • But why? this is the point of synchronization, no? To update older files with newer version of them! So it shouldn't ask, and I think in the past, this problem was not present. – Tomas Dec 5 '14 at 13:18
  • Ahh, got it work, see my answer! Thank you very much though, this explicit action would be an interesting feature to use. – Tomas Dec 5 '14 at 13:23
  • @Tomas Glad you resolved it. I had no idea about the effect of ignore date option, +1 for your solution – Bohuslav Burghardt Dec 5 '14 at 13:42
  • Thanks Bohuslav. Your answer brought me to that idea! I was thinking that TotalCommander is completely buggy :) – Tomas Dec 5 '14 at 13:48
1

It was because I had the option "ignore date" checked! When this option is checked, you must do what @Bohuslav is suggesting, i.e. manually add these files to synchronization. But when I uncheck this option, it works as expected, i.e. the newer files are synchronized automatically!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.