-3

I'm not exactly sure how this happened, but I think something uninstalled my computer's touchpad driver, as enhancements like momentum and gestures stopped working. I downloaded and installed an update, which did set up, but Synaptics' menu in Mouse options is missing, the gestures aren't back, and I got some error notification about the touchpad being non-authentic. I have not modified anything about this computer though, and have only recently messed with the drivers at all.

This is a HP Pavilion laptop, with a touchscreen, running Win8.1 64bit. The driver I installed came from the the Synaptics site's drivers page. Ask me if more details are needed.

  • 1
    Please provide the exact error. Have you installed the drivers located on HP's website? What version of the drivers did you installed? – Ramhound Dec 1 '14 at 16:07
  • Edited. Added the link: synaptics.com/en/drivers.php – Vector Lightning Dec 1 '14 at 16:30
0

U can try this driver:

Open uninstall programs and uninstall Synaptics' program if it's present in the list. Open device manager, expand the mouse tree, right click on the mouse inside the tree and click 'uninstall'. Reboot your computer. Install version 15.3.25 of Synaptics driver by HP: ftp://ftp.hp.com/pub/softpaq/sp54501-55000/sp54906.exe and reboot after installation. Did Synaptics' menu in mouse options come back?

  • I... can't test it, I got it fixed after I figured out that you can rollback a driver. I'd try it though, thank you. – Vector Lightning Dec 7 '14 at 1:54
0

I just solved this myself a while ago, I found that you can rollback a driver with the Device Manager, and this fixed it perfectly.

Although I'm still confused as to how it broke, I never updated it until it broke down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.