1

Summary

This has been an ongoing issue across Windows 8 and up where the windows full screen apps fail to open without instantly crashing while the skydive fails to function at all. The only ('temporary') solution is a fresh reinstall or reset while no amounts of sfc /scannow and dism /online /cleanup-image /restorehealth helps the issue. These file correction software fail with errors simultaneously with the corruption of the apps/SkyDrive.

Hardware

Computer:
  Computer Type                                     ACPI x64-based PC  (Mobile)

Motherboard:
  CPU Type                                          Mobile QuadCore AMD A6-3400M, 3100 MHz (31 x 100)
  Motherboard Name                                  HP 358B
  Motherboard Chipset                               AMD A70M, AMD K12
  System Memory                                     5610 MB  (DDR3-1333 DDR3 SDRAM)
  DIMM1: Samsung M471B5773CHS-CH9                   2 GB DDR3-1333 DDR3 SDRAM  (9-9-9-24 @ 666 MHz)  (8-8-8-22 @ 609 MHz)  (7-7-7-20 @ 533 MHz)  (6-6-6-17 @ 457 MHz)  (5-5-5-14 @ 380 MHz)
  DIMM2: SK Hynix HMT351S6BFR8C-H9                  4 GB DDR3-1333 DDR3 SDRAM  (9-9-9-24 @ 666 MHz)  (8-8-8-22 @ 609 MHz)  (7-7-7-20 @ 533 MHz)  (6-6-6-17 @ 457 MHz)  (5-5-5-14 @ 380 MHz)
  BIOS Type                                         Insyde (09/13/2011)

Storage:
  IDE Controller                                    AMD SATA Controller
  IDE Controller                                    Realtek PCIE CardReader
  IDE Controller                                    Standard Dual Channel PCI IDE Controller
  Storage Controller                                Microsoft Storage Spaces Controller
  Disk Drive                                        Hitachi HTS547550A9E384  (500 GB, 5400 RPM, SATA-II)
  Optical Drive                                     hp       CDDVDW TS-L633R
  SMART Hard Disks Status                           OK

Partitions:
  C: (NTFS)                                         446.6 GB (234.1 GB free)
  D: (NTFS)                                         19434 MB (808 MB free)
  F: (NTFS)                                         144 MB (60 MB free)
  Total Size                                        465.7 GB (234.9 GB free)

DMI:
  DMI BIOS Vendor                                   Hewlett-Packard
  DMI BIOS Version                                  F.21
  DMI System Manufacturer                           Hewlett-Packard
  DMI System Product                                HP Pavilion dv6 Notebook PC
  DMI System Version                                058A110014244610000620100
  DMI System Serial Number                          5CH1411U6U
  DMI System UUID                                   D631D367-033561A4-73AE101F-741C01C8
  DMI Motherboard Manufacturer                      Hewlett-Packard
  DMI Motherboard Product                           358B
  DMI Motherboard Version                           33.18
  DMI Motherboard Serial Number                     PBYSF02HT1I8JI
  DMI Chassis Manufacturer                          Hewlett-Packard
  DMI Chassis Version                               Chassis Version
  DMI Chassis Serial Number                         Chassis Serial Number
  DMI Chassis Asset Tag                             Chassis Asset Tag
  DMI Chassis Type                                  Notebook

Outside research

Microsoft support forums again and again claim these issues to be 'profile corruption' and usually consist of asking users to perform the sfc and dism commands and/or submit their logs if this is done before never responding again. Sometimes they will reference how to troubleshoot troubleshooters which troubleshoot troubleshooters, or recovery programs to recover the recovery programs, etc. in an endless stream of uselessness and failures. These issues appear to be widespread among windows users.

Symptoms

Windows 8 'apps'

Windows 8 apps will crash on start. This includes PC settings and the like.

SkyDrive

SkyDrive will no longer synch. The icon disappears from context menu at left. The SkyDrive troubleshooting pack cabinet (onedrivets.diagcab) displays this: OneDrive Troubleshooter

then this:

enter image description here

Claiming that SkyDrive is 'off'. When I start the application, it opens the SkyDrive folder, hangs then crashes. I tried to uninstall and reinstall SkyDrive, and now the app doesn't even start, but still yields the exact same messages from the SkyDrive troubleshooter as before.

Event Log http://1drv.ms/1rVOZ44

This event log holds all relevant errors from when the problems first started. Notable error events are a whole bunch of registry 'database' corruption (some with UsrClass.dat), we can see where skyDrive took a pitch with its KERNELBASE.dll (event 1000) and also the 'This app does not support the contract specified or is not installed.' I got with certain windows 8 apps when they did not start and gave me a dialog box with an error (event 5973). I apologize for the somewhat large size, as I am not all that familiar with the windows event logs

Attempts at recovering the recover-ers

Naturally the very first time I had these symptoms I hopped into powershell and used the sfc, dism commands to try and recover the corrupted windows files. Sfc failed with errors while Dism just hung for two days at 20%. Whenever user with this windows app/SkyDrive corruption happens these recovery tools seem guaranteed to fail to fix the problems. Here are the logs:

http://1drv.ms/1tFpJJt

-I included additional logs besides the cbs.log from sfc and dism.log from dism for extra reference.

13
  • Yes, I know I didn't include ChkDsk, but the other times I tried this before re-installing I believe it failed too. Dec 1 '14 at 23:19
  • What relevant events are logged in Event Viewer? Dec 5 '14 at 1:11
  • @Twisty I see a lot of 'registry database' and/or C:\Users\Bennett\AppData\Local\Microsoft\Windows\\UsrClass.dat and a few system32 dll's are corrupted and 'cannot load classes registry' and a lot of other things. Would you like me to post a link of my Windows Logs > Application log? Dec 5 '14 at 1:20
  • 1
    Is the hard drive possibly failing? Run the drive's bootable diagnostic CD. Dec 5 '14 at 2:39
  • 1
    @Twisty I have experienced this many times on the machine I'm currently on and on another old Everex desktop computer (Everex went out of business a while, they make really bad computers). Dec 5 '14 at 22:52
0

After upgrading to an new Solid State Drive and experiencing no issues, it appeared that these issues were caused by hard drive errors. My hard drive was over 5 years old and consistently caused errors after fresh re-installs of windows. I am currently in the Windows 10 technical preview and windows did not mention any fixes for these issues, so I am strongly convinced these issues would recur even in the new windows OS.

Edit: More than a year from last update Jan 10 (2014) at 1:45 and still no sign of the issues.

Edit: September 28 2016 and still chugging away like a champ, I think I can attribute the problem to hard drive failure.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .