1

I'm using guacamole (http://guac-dev.org/) to access (parts of) my home (Debian) computer clientless, on the go.

From my work computer (University Network) the screen is however not updating and only shows "Connecting, waiting for first update...". According to the FAQ (http://guac-dev.org/doc/gug/troubleshooting.html) this is likely due to a proxy between my home and my work computer not flushing it's buffer, and can be solved by using https.

I did that by: (1) Creating my own certificate following (www.heimpold.de/mhei/mini-howto-zertifikaterstellung.htm) and adding to a keystore-file (2) Adding to the tomcat6 server.xml:

 <Connector
       protocol="org.apache.coyote.http11.Http11Protocol"
       port="8443" maxThreads="200"
       scheme="https" secure="true" SSLEnabled="true"
       keystoreFile="/usr/share/tomcat/.keystore" keystorePass="mypassword"
       clientAuth="false" sslProtocol="TLS"/>

(3) Adding to the guacd config file:

guacd-ssl: true

I can actually access https://localhost:8443/guacamole and login, yet, when I try to actually open a session (i.e. view my home-desktop) I get Server error (in quacamole design, not like a browser or http error message) in my browser window. At the same time the tomcat-log file states:

SEVERE: Server error in tunnel
[...] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

(full log available at http://pastebin.com/qeaiNKRM)

  • Why post another variant superuser.com/questions/847347/… ? – Rsya Studios Dec 1 '14 at 23:45
  • Well, here I'm asking how to correct the https setup. There I'm asking how to solve my issue without using https. Two distinct questions: Two topics. Not good? – sheß Dec 2 '14 at 1:09
  • Now, I started using noVNC instead, which does the trick for me. – sheß Dec 2 '14 at 14:15
0

Have you tried removing/commenting:

guacd-ssl: true

on guacd config file...

This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.