1

After installing Yosemite, I am unable to download any apps from the Yosemite App Store.

I can view the "Featured" section of the App Store, but when I click on any of the apps, I'm faced with a blank page.

I've tried several suggestions from the Apple community site (resetting NVRAM, resetting user ACLs, etc), but nothing has worked. Has anyone experienced this issue, and if so, how did you resolve it?

0

I experienced this exact issue. For me, it was being caused by Little Snitch. I had already allowed rules for the app store, but it was doing something else, and silently failing.

My solution was to search the Little Snitch Configuration tool for store, and delete any rules for storeaccountd and storeassetd.

Then, re-launch the Mac App Store, and "Allow any outgoing connection, Forever" for both of these processes. Note that limiting them by port/host won't work. You have to allow all connections for both of these processes.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.